RunRyder RC
WATCH
 1 page 516 views POST REPLY
12-27-2010 04:19 AM  9 years ago
Topic Vote0Post 1
gingus1

rrApprentice

Lafayette,La.

MyPosts All Forum Topic
Battery advice
Hi' i need some advice on weather to use my battery are dispose of it. I have a new never used yet Hyperion G3 CX 2500mAh 2S 7.4V 25C/45C Lipo Pack which had a balancing plug that doesn't work on anything i have so as i was tempting to change it out i accidentally touched the two black wires which i pulled apart very quickly. It did discolor the connections but did not melt the insulators over the wire. I'm wondering if it's still safe to use on my heli. Any input would be appreciated. Thanks.
You Da-Man
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
12-27-2010 11:00 AM  9 years ago
Rotor Trash

rrApprentice

Higginsville, MO

MyPosts All Forum Topic
You better send it to me. I'm sure it's toast Load'r High and Let'r Fly !!!
SHARE  PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
12-27-2010 12:03 PM  9 years ago
Gyronut

rrProfessor

Martinsville In.

MyPosts All Forum Topic
💎Sustaining Member
Just give it a charge and see how it come out..Rick
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
12-27-2010 12:17 PM  9 years ago
McKrackin

rrProfessor

Lucasville,Ohio

MyPosts All Forum Topic
I doubt it hurt anything.
The balance wires don't carry any real amperage.
They're too small.
The entire wire can melt in two before damaging a battery cell.
I literally never use the word literally right.
SHARE  PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
12-27-2010 12:34 PM  9 years ago
Mike0251

rrVeteran

Hills of the Blue Ridge VA

MyPosts All Forum Topic
Charge it under supervision. Install it and test hover for 3-5 minutes at a low altitude. Charge again and check the amount of amps it drew on the hover test. If all seems good, it balances correctly, fly the crap out it.
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
12-27-2010 02:11 PM  9 years ago
gingus1

rrApprentice

Lafayette,La.

MyPosts All Forum Topic
Thanks, Well i had checked it when it first came in before this happened and it was something like 3.78 v. per cell in that nature. I put a charge on it after i touched the wires together an the battery did not swell are get hot are even warm. When charge was completed the volts read cell 1 at 4.15 and cell 2 at 4.19 but as soon as the charge was completed i unplugged it an didn't let it trickle to balance out. Guess I'll try it hovering. It's going in a new 600n Le i just finished building. Thanks for all the input guys appreciate it.You Da-Man
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 516 views POST REPLY
 Print TOPIC  Make Suggestion 

 0  Topic Subscribe

Saturday, February 29 - 5:54 am - Copyright © 2000-2020 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online