RunRyder RC
WATCH
 1 page 388 views POST REPLY
HomeRC & Power✈️Aircraft🚁HelicopterRadio - Servo - Gyro - Gov - Batt › help with switch glow pro
12-21-2010 06:39 PM  9 years ago
Topic Vote0Post 1
gotnoclue

rrApprentice

sydney

MyPosts All Forum Topic
help with switch glow pro
i have a new switch glow pro ive just installed, started up fine but when i came back to to low throotle, when my glow normally kicks in the unit just started doing 2 second beeps at me.

power cycled everything but still getting the same beeping even before engine has started, never had this problem on any of my other switch glow units before and they are all setup the same way.

i changed plugs but still get the same 2 second beeping that does not stop
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
12-21-2010 09:36 PM  9 years ago
alfred

rrVeteran

Australia, New South Wales, Mid North Coast

MyPosts All Forum Topic
Do you have a spare Switch channel that you can use for the moment as a quick test?
If so, set the endpoints to +100%/-100%
Then plug it in and see if it still does the same.
If it doesn't then your mixing settings might just be on the fence.
SHARE  PM  EMAIL  Attn:RR  Quote
12-22-2010 06:28 AM  9 years ago
gotnoclue

rrApprentice

sydney

MyPosts All Forum Topic
sadly its plugged in using a y lead to my total g on the throttle channel, same set up and mix onn my other heli and its perfect.

have got a few things to look over that switchglo have mentioned so see how i go
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 388 views POST REPLY
HomeRC & Power✈️Aircraft🚁HelicopterRadio - Servo - Gyro - Gov - Batt › help with switch glow pro
 Print TOPIC  Make Suggestion 

 1  Topic Subscribe

Wednesday, February 19 - 4:28 pm - Copyright © 2000-2020 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online