RunRyder RC
WATCH
 1 page 652 views POST REPLY
HomeRC & PowerAircraftHelicopterRadio - Servo - Gyro - Gov - Batt › Multi gov pro doesnt seem to work.
10-13-2010 01:29 PM  8 years agoPost 1
jake21

rrApprentice

ontario canada

My Posts: All  Forum  Topic

I have a multi gov pro in a raptor 50 with an os 70 in it swinging 620 blades at 2000 rpm and a gear ratio of 8.5. All bench testing tells me that everything is ok. During stationary flips and rolls the engine bogs severe. I can tune it from rich to lean and it gets worse in both directions. Everything is new. Please help.

The only way to not crash is up

PM  EMAIL  GALLERY  Attn:RR  Quote
10-13-2010 02:16 PM  8 years agoPost 2
Heli 770

rrProfessor

USA.

My Posts: All  Forum  Topic

I don't think it's your Gov. At 2,000rpm head speed your OS 70 is 1,000rpm over its peak power range.

PM  EMAIL  Attn:RR  Quote
10-13-2010 02:29 PM  8 years agoPost 3
z11355

rrMaster

New England

My Posts: All  Forum  Topic

you really ought to consider breaking in the engine rich and turning off the gov until you get a solid # of tanks through it.

this sounds like a recipe for not working well

PM  EMAIL  GALLERY  Attn:RR  Quote
10-13-2010 03:31 PM  8 years agoPost 4
jake21

rrApprentice

ontario canada

My Posts: All  Forum  Topic

The engine had 7 tanks through it at factory specs before the governor was activated.
I have stunt 1 set at 1885 head speed and it bogs the same.
I dont think this engine should ever bog with 620 blades.
It works fine when I disconnect the governor and put in a 30% throttle mix.

The only way to not crash is up

PM  EMAIL  GALLERY  Attn:RR  Quote
10-13-2010 04:41 PM  8 years agoPost 5
z11355

rrMaster

New England

My Posts: All  Forum  Topic

fair enough but I'll say that gov's tend to want to have a leaner engine than a human would and that may not be appropriate for a 'newish' engine

PM  EMAIL  GALLERY  Attn:RR  Quote
10-13-2010 04:54 PM  8 years agoPost 6
ostatebucki1

rrNovice

Cincinnati, OH, USA

My Posts: All  Forum  Topic

Set up a linear throttle curve. Make sure the gov is turned off. Hover the heli and add full collective to do a quick climbout. Does the engine bog or cut out? If so, your engine is too rich or too lean. Headspeed should stay the same. Once you have this worked out, turn the gov on.

BTW, what throttle servo are you using and what are your collective and cyclic pitches?

Zach
Velocity 50

PM  EMAIL  GALLERY  Attn:RR  Quote
10-13-2010 05:04 PM  8 years agoPost 7
jake21

rrApprentice

ontario canada

My Posts: All  Forum  Topic

Collective pitch is 12 and cyclic is 7.
I have heard that this engine will do that with 680 blades.
The way you mentioned to tune the engine is what I always do.
It just seems like the gov. is not working at all.

The only way to not crash is up

PM  EMAIL  GALLERY  Attn:RR  Quote
10-13-2010 08:04 PM  8 years agoPost 8
philthewrench

rrApprentice

Westchester Co. NY

My Posts: All  Forum  Topic

It just seems like the gov. is not working at all
Does you HS change in a hover when you change it in the Multigov setup?

Phil

... and now my impression of a lawn dart .......

PM  EMAIL  GALLERY  Attn:RR  Quote
10-13-2010 10:13 PM  8 years agoPost 9
ostatebucki1

rrNovice

Cincinnati, OH, USA

My Posts: All  Forum  Topic

OK. Did you set your low and high throttle points in the governor menu? Did you test to see that only ONE of the magnets is being detected by the sensor (test indicates ON when magnet is under sensor)?

When you start your heli, the led on the multigov should be flashing really fast meaning that the magnet is detected.

Zach
Velocity 50

PM  EMAIL  GALLERY  Attn:RR  Quote
10-14-2010 03:20 PM  8 years agoPost 10
jake21

rrApprentice

ontario canada

My Posts: All  Forum  Topic

Only one magnet and it reads properly.
High and idle have been set many time and tested.
Blue light does what it is suppose to.
When switching flight modes nothing changes.
The only thing that is different in the flight modes is the rpm setting.
I set one mode to 750 rpm and it will slow down but when I move the collective up it does not stay there. It returns to the throttle curves.
It seems like the gov is intermittent.
Thanks Jake.

The only way to not crash is up

PM  EMAIL  GALLERY  Attn:RR  Quote
10-14-2010 08:12 PM  8 years agoPost 11
philthewrench

rrApprentice

Westchester Co. NY

My Posts: All  Forum  Topic

You may want to refer to the set up directions, there is a way to return the unit to default settings, perhaps you messed up one of the settings without knowing about it.

You might also want to check low throttle percent, and also see if it woks correctly in gov test mode.
I set one mode to 750 rpm and it will slow down but when I move the collective up it does not stay there. It returns to the throttle curves
I'm gonna assume 1750? and how do you know it returns to throttle curves? Is rpm decreasing?

Phil

... and now my impression of a lawn dart .......

PM  EMAIL  GALLERY  Attn:RR  Quote
10-14-2010 08:53 PM  8 years agoPost 12
Aerospire

rrApprentice

Honolulu, HI

My Posts: All  Forum  Topic

I'm gonna assume 1750? and how do you know it returns to throttle curves? Is rpm decreasing?

Phil
Phil/Zach,

Really appreciate you and others trying to help. I've been talking to Jake via e-mail also.

Thanks,
bob

PM  EMAIL  GALLERY  Attn:RR  Quote
10-14-2010 08:55 PM  8 years agoPost 13
jake21

rrApprentice

ontario canada

My Posts: All  Forum  Topic

Have went to default setting and started over twice.
With the throttle curves and the pitch curves the same in all modes the rpm does not change when I switch modes.
If it was not running on the throttle curves it would change rpm based on the gonernor rpms that I have set at 3 different speeds.
I have only read good things about the multi gov. But I probably wouldnt be the first one to get a bad one.
I am also working with Bob at Aerospire to solve this problem.
Thanks Jake.

The only way to not crash is up

PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 652 views POST REPLY
HomeRC & PowerAircraftHelicopterRadio - Servo - Gyro - Gov - Batt › Multi gov pro doesnt seem to work.
 Print TOPIC  Make Suggestion 

 2  Topic Subscribe

Tuesday, December 11 - 9:02 pm - Copyright © 2000-2018 RunRyder   EMAILEnable Cookies

The RC discussion world needs to consolidate. RR is now one choice for that. Its software is cutting edge. It hosts on-topic advertising. Help RR increase traffic buy making suggestions, posting in RR's new areas (sites) and by spreading the word.

The RunRyder Difference

• Category system to allow Rep/Vendor postings.
• Classifieds with sold (hidden) category.
• Classifieds with separate view new.
• Answer PMs offsite via email reply.
• Member gallery photos with advanced scripting.
• Gallery photo viewer integrated into postings.
• Highly refined search with advanced back end.
• Hosts its own high end fast response servers.
• Hosts thousands of HD event coverage videos.
• Rewrote entire code base with latest technology.
• No off-topic (annoying) click bait advertising.
Login Here
 New Subscriptions 
 Buddies Online