RunRyder RC
WATCH
 1 page 615 views POST REPLY
HomeAircraftHelicopter
e-
Castle Electric Components
› castle ice100esc
04-11-2010 01:00 AM  8 years agoPost 1
2low

rrApprentice

elkview,WV

My Posts: All  Forum  Topic

I am experiencing a problem with my 100ice. I have programed it numerous times trying to get it the way I want it. It is not letting me give a low stick no option. It will let me make a yes high stick for yes but not a low stick no. I thought I would try arming it and to see what the does not but I only get a steady red flash. What gives? Thanks.

Got to have my cup of heli in the morning.

PM  EMAIL  GALLERY  Attn:RR  Quote
04-11-2010 01:25 AM  8 years agoPost 2
michael88997

rrElite Veteran

Lewisville,Tx

My Posts: All  Forum  Topic

you probably need to take your throttle end point further where it will read it

PM  EMAIL  GALLERY  Attn:RR  Quote
04-11-2010 01:32 AM  8 years agoPost 3
2low

rrApprentice

elkview,WV

My Posts: All  Forum  Topic

Thanks, but Iv programmed it about 4 times. I was in the process doing it and all of a sudden it quit letting me give a low stick no for any of the programs options. When I power up the esc now I get a steady red flash. I had it flying really well and just wanted to make one change.

Got to have my cup of heli in the morning.

PM  EMAIL  GALLERY  Attn:RR  Quote
04-11-2010 01:37 AM  8 years agoPost 4
michael88997

rrElite Veteran

Lewisville,Tx

My Posts: All  Forum  Topic

did u buy it new?

PM  EMAIL  GALLERY  Attn:RR  Quote
04-11-2010 01:54 AM  8 years agoPost 5
Sar

rrElite Veteran

Saugeties, NY

My Posts: All  Forum  Topic

That's weird, sure you didn't hit Idle Up trying to 3D the configuration?

Worst case, give Castle a call, their customer support has been great in my experience, also the Castle Link is nice. Sometimes that stick programming is annoying and you also can access some of the other stuff like new firmware, extended configuration, etc. Either way, hope you have found a solution already.

--
Jon

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
04-11-2010 01:59 AM  8 years agoPost 6
2low

rrApprentice

elkview,WV

My Posts: All  Forum  Topic

Hey Michael88997 I tried what you said and sure enough that did it. Bumped up travel on throttle from 100 to 110, worked like a charm. Cant figure out why all of a sudden it could not read low stick at 100. Anyhoo thanks for all the help. I keep learning so much stuff from the help I get on here. Thanks again.

Got to have my cup of heli in the morning.

PM  EMAIL  GALLERY  Attn:RR  Quote
04-11-2010 11:00 AM  8 years agoPost 7
2low

rrApprentice

elkview,WV

My Posts: All  Forum  Topic

I know this question has been asked but maybe more have used this escs built in bec to run servos and gyro. I have about 6 flights on my 600 now just using the built in bec with no problems. Should I be using the 6x bec the kit comes with the kit? Thanks.

Got to have my cup of heli in the morning.

PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 615 views POST REPLY
HomeAircraftHelicopter
e-
Castle Electric Components
› castle ice100esc
 Print TOPIC  Make Suggestion 

 1  Topic Subscribe

Monday, August 20 - 6:08 am - Copyright © 2000-2018 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online