RunRyder RC
WATCH
 1 page 700 views POST REPLY
HomeAircraftHelicopterThunder TigerRAPTOR 50 › titan se swashplate question
04-08-2010 01:57 PM  8 years agoPost 1
Lirann

rrNovice

israel

My Posts: All  Forum  Topic

hello everyone,

does anybody know if the metal swashplate felt kind of stiff to turn or move by hand when new? i put oil inside and then put it back on the main shaft with all the linkages attached, and the controls feel a little hard beacuse of the swashplate, no servos yet, bran new assembly. is this normal? or the swash needs to be replaced?

thanx

liran

PM  EMAIL  GALLERY  Attn:RR  Quote
04-08-2010 07:16 PM  8 years agoPost 2
Heli 770

rrProfessor

USA.

My Posts: All  Forum  Topic

You may have a little longer than normal ball screw that is putting tension against the outer race of the swash bearing that is causing your binding problem.

PM  EMAIL  Attn:RR  Quote
04-08-2010 07:44 PM  8 years agoPost 3
Lirann

rrNovice

israel

My Posts: All  Forum  Topic

heli770
checked the ball screws with a screwdriver but all four are snuged in as supposed to be.
thanx.

liran

PM  EMAIL  GALLERY  Attn:RR  Quote
04-09-2010 07:15 AM  8 years agoPost 4
RAPTOR 4D

rrVeteran

GRANGER,IN,-USA

My Posts: All  Forum  Topic

Ive had them feel pretty tight when new as they do
loosen up without an issue. You should be just fine,
better tight than loose you dont want any slop.

Raptor 50 Titan SE

PM  EMAIL  GALLERY  Attn:RR  Quote
04-09-2010 09:41 AM  8 years agoPost 5
magster

rrNovice

NH

My Posts: All  Forum  Topic

You are saying that it is stiff with all the linkages on. Are you sure it is the swash? The problem could be tight ball links. Every Raptor I have built has had tight links. So bad infact, that they will make the servos buzz in the center position. I resize all my links with the Mavrikk resizer and everything smooths out. It only takes a very small amount of material removal from the link to get it smooth.

PM  EMAIL  GALLERY  Attn:RR  Quote
04-09-2010 05:51 PM  8 years agoPost 6
Lirann

rrNovice

israel

My Posts: All  Forum  Topic

resizing linkages
You are saying that it is stiff with all the linkages on. Are you sure it is the swash? The problem could be tight ball links. Every Raptor I have built has had tight links. So bad infact, that they will make the servos buzz in the center position. I resize all my links with the Mavrikk resizer and everything smooths out. It only takes a very small amount of material removal from the link to get it smooth.
i ment that the swash is stiff when i turn or move it even with all the linkages off.
I'm indeed familiar with the linkages resizing process and do that anyway as part of the assembly as you described with the resizing tool.
Ive had them feel pretty tight when new as they do
loosen up without an issue. You should be just fine,
better tight than loose you dont want any slop.
that's what i was thinking.

thank you guys for all your inputs

liran

PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 700 views POST REPLY
HomeAircraftHelicopterThunder TigerRAPTOR 50 › titan se swashplate question
 Print TOPIC  Make Suggestion 

 1  Topic Subscribe

Friday, August 17 - 2:10 pm - Copyright © 2000-2018 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online