RunRyder RC
WATCH
 1 page 376 views TOPIC CLOSED
04-06-2010 06:51 AM  8 years agoPost 1
OuttaControl

rrVeteran

Springfield, Missouri -United states

My Posts: All  Forum  Topic

I have a Castle esc that I took off a heli and reinstalled it on another one. It worked fine on the first heli. Now when you plug in the battery it beeps 4 times and a red LED starts flashing. Also the AR7000 will not power up. It will with a separate battery. I don't have any literature on the esc so I'm at a loss on what to do. Any help will be appreciated.

PM  EMAIL  GALLERY  Attn:RR
WATCH
 1 page 376 views TOPIC CLOSED
 Print TOPIC  Make Suggestion 

 0  Topic Subscribe

Thursday, October 18 - 4:01 am - Copyright © 2000-2018 RunRyder   EMAILEnable Cookies

The RC discussion world needs to consolidate. RR is now one choice for that. Its software is cutting edge. It hosts on-topic advertising. Help RR increase traffic buy making suggestions, posting in RR's new areas (sites) and by spreading the word.

The RunRyder Difference

• Category system to allow Rep/Vendor postings.
• Classifieds with sold (hidden) category.
• Classifieds with separate view new.
• Answer PMs offsite via email reply.
• Member gallery photos with advanced scripting.
• Gallery photo viewer integrated into postings.
• Highly refined search with advanced back end.
• Hosts its own high end fast response servers.
• Hosts thousands of HD event coverage videos.
• Rewrote entire code base with latest technology.
• No off-topic (annoying) click bait advertising.
Login Here
 New Subscriptions 
 Buddies Online