RunRyder RC
WATCH
 1 page 522 views Post Reply
HomeRC & Power✈️Aircraft🚁HelicopterRadio - Spektrum DSM › spektrum module problem
03-30-2010 02:52 AM  10 years ago
Topic Vote0Post 1
shermer-high

rrNovice

ct

MyPosts All Forum Topic
spektrum module problem
I just installed a spektrum module in my 9z.I bound 3 helis after a couple flights on 2 I ran into a problem.I turned on the tx then the heli and all the servos were twitching,buzzing and going crazy with no tx control. Next I tried the heli before the tx that worked a couple times but not always.It does this on both helis I tried.I also tried to bind my msr that just twitched like crazy.Even rebinding does not help.But then all of a sudden everything works.It's hit or miss if it works.I also noticed the module makes a buzzing noise.any ideas?
SHARE  PM  EMAIL  Attn:RR  Quote
03-30-2010 03:03 AM  10 years ago
z11355

rrMaster

New England

MyPosts All Forum Topic
sounds like a bad module or perhaps you dont have the module seated fully in the hole in the back of the 9Z.

My Spektrum module works fine on my 9Z.
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
03-30-2010 03:08 AM  10 years ago
shermer-high

rrNovice

ct

MyPosts All Forum Topic
I did unplug and reinstall the module a bunch of times to check for seating.
SHARE  PM  EMAIL  Attn:RR  Quote
03-30-2010 12:37 PM  10 years ago
BarracudaHockey

rrMaster

Jacksonville FL

MyPosts All Forum Topic
Sure sounds like it got set to PCMAndy
AMA 77227
http://www.jaxrc.com
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
03-30-2010 01:00 PM  10 years ago
MarkToo

rrApprentice

Cambridge, ON

MyPosts All Forum Topic
I had a similar problem with my module system on my 10X. It turned out to be a bad connection within the antenna. Moving the antenna around to different orientations would cause this issue. There must have been a break in the shielded wire somewhere. I bought a $15 replacement antenna and never had the problem again.
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
03-31-2010 05:05 AM  10 years ago
shermer-high

rrNovice

ct

MyPosts All Forum Topic
Problem solved! This started when I tried to bind my msr.I forgot to change that model program to ppm which sometimes messed with the other helis on different programs.Barracudahocky hit the nail on the head.Thanks guys.
SHARE  PM  EMAIL  Attn:RR  Quote
WATCH
 1 page 522 views Post Reply
HomeRC & Power✈️Aircraft🚁HelicopterRadio - Spektrum DSM › spektrum module problem
Print TOPIC

 3  Topic Subscribe

Sunday, October 25 - 1:18 am - Copyright © 2000-2020 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online