RunRyder RC
WATCH
 1 page 642 views Post Reply
Home✈️Aircraft🚁Helicoptere-MikadoOther › Another black Sunday
03-01-2010 12:21 AM  10 years ago
Topic Vote0Post 1
Qrrambero

rrKey Veteran

San Francisco / Bay Area

MyPosts All Forum Topic
Another black Sunday
Here I am again.
Crashed my New Logo 600 (Again) and I do not know what happened.
Just a nice fly a pirouette here, a flip there, few rolls, inverted fly and suddenly the Heli did a 1/2 pirouette and the nose dove to the ground.
Any Idea why? Some one said that could be a glitch, but I have a JR 12X/ DSM and I grounded the tail as I did with my Logo 400. The bell did not jump this time, because I put a screw and the screw was there after the crash. The bell was broken in three pieces, but the boom was all twisted. Main shaft broken in two pieces.
Sorry for the whining I just need and idea what happen. I do not want to put it together and it does again.
Thanks.

Ae
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
03-01-2010 12:27 AM  10 years ago
Steff Giguere

rrProfessor

St-Eustache, Quebec, Canada

MyPosts All Forum Topic
I'm crying for you.Team Synergy, Rail blades, Team Scorpion, V-Team
SHARE  PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
03-01-2010 12:39 AM  10 years ago
Qrrambero

rrKey Veteran

San Francisco / Bay Area

MyPosts All Forum Topic
Why? for the Hockey Game ? Ae
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
03-01-2010 12:56 AM  10 years ago
misfits0311

rrKey Veteran

Santa Clarita, CA - USA

MyPosts All Forum Topic
I had that happen on my T700. Mine was due to the carbon fiber eating through the spektrum satellite wire. Did you see the swash jump or twitch prior to the crash? I would rule out the satellites first. A thorough inspection of each wire may reveal something. Also, are you using an external BEC? That could be the culprit too.╘ₒ₲ₒ 6°° ƺƉ ṾЪ∂®
SHARE  PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
03-02-2010 05:19 PM  10 years ago
Big Fil

rrKey Veteran

Santa Rosa, CA

MyPosts All Forum Topic
Sorry to hear about that on top of the lipo fire destroying your 400. Sounds like the sensor wire might have come loose on you in flight. Did you have it secured?
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 642 views Post Reply
Home✈️Aircraft🚁Helicoptere-MikadoOther › Another black Sunday
Print TOPIC

 2  Topic Subscribe

Saturday, December 5 - 9:56 am - Copyright © 2000-2020 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online