RunRyder RC
WATCH
 1 page 3268 views Post Reply
HomeRC & Power✈️Aircraft🚁HelicopterRadio - Futaba FASST › Mismatched RF-Module -- Futaba 14MZ
02-23-2010 04:02 PM  10 years ago
Topic Vote0Post 1
bchen3

rrNovice

Honolulu, Hawaii - USA

MyPosts All Forum Topic
Mismatched RF-Module -- Futaba 14MZ
Has anyone experienced this before? My futaba 14MZ radio is displaying "Mismatched RF-Module" messege while I was setting up my helicopter. I've been using this radio for the whole flying season with the TM-14 module. The radio and the TM-14 module was purchased in USA. It has been running fine with the 2.4Ghz TM-14 module and the 6014fs rx in my other two helis for the whole season. Nothing change, I noticed the "futaba" sign was blinking while I was setting up the my new heli, I turn off the TX, when I power back on the TX displayed "Mismatched RF-Module", if I continue, TX will not transmit. I've tried the update to firmware but the problem still exist. Do I need to send the radio in for service or is there other test I can try? Please advice.

Version:

WindowsCE Ver.4.20 (0)
Editor Ver. 1.3.2
Encoder Ver. 1.41
Language: English
SHARE  PM  EMAIL  Attn:RR  Quote
02-23-2010 05:05 PM  10 years ago
hpilotrc

rrVeteran

NY--->>Mooresville, NC USA 8/2005

MyPosts All Forum Topic
Mismatched RF module....
Are you sure the TM-14 module is fully seated (try inserting it again), and the modulation type selected is the 2.4GHz band? The new model selected might by default have another band selected?

Good luck,

Michael
SHARE  PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
02-23-2010 05:24 PM  10 years ago
bchen3

rrNovice

Honolulu, Hawaii - USA

MyPosts All Forum Topic
thanks for the advice. Yes the TM-14 module is seated properly (tried many times). In the frequency menu, it will not allow me to change, right now the system is set at "Fasst Mult".
SHARE  PM  EMAIL  Attn:RR  Quote
02-23-2010 05:35 PM  10 years ago
hpilotrc

rrVeteran

NY--->>Mooresville, NC USA 8/2005

MyPosts All Forum Topic
TM-14 module
The problem could be the transmitter but most likely is (my guess) the TM-14 module. Looks like the transmitter isn't recognizing the TM-14 module. Does anyone have another module you could try?

Make sure there aren't any bent pins on the module if possible. I think they are pretty small from what I remember on mine.

good luck,

Michael
SHARE  PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
02-23-2010 10:44 PM  10 years ago
A&J

rrApprentice

Hudson FL 34667

MyPosts All Forum Topic
💎Sustaining Member
have all the Software Update.....if not go here

http://2.4gigahertz.com/downloads/downloads.html
Lets do the time warp againnn !
SHARE  PM  EMAIL  Attn:RR  Quote
02-24-2010 03:30 PM  10 years ago
bbaxter

rrApprentice

Central Illinois

MyPosts All Forum Topic
Please check the model. When you get a mis-match message from the transmitter, it does allow you to bypass the message. Then you can go to the main screen, but the transmitter will not be on the air. Now enter the Linkage Menu and then the Frequency section. The frequency may not be one that's compatible with the module in the transmitter. For example, a 72 MHz model memory when you have the 2.4 GHz FASST module installed. That will cause such a mis-match message.
SHARE  PM  EMAIL  Attn:RR  Quote
02-24-2010 04:28 PM  10 years ago
bchen3

rrNovice

Honolulu, Hawaii - USA

MyPosts All Forum Topic
Once again, thank you all for the sound advice. Unfortunately the problem still exist. On the start up screen, it displayed "Band No. (Freq.CH): 2.4GHz MULT" I can bypass the error messege, and go to the linkage menu and select Frequency, the system is set at "FASST MULT" and on the right hand side of the screen, it states "RF module is not attached. Can not change setting". Remember, I have no problem using the TM-14 2.4 GHz FASST on this radio the whole season with my other helis, this all happened when I was in the middle of setting up another heli, I was able to control all the servo movements, then all at once I lost all control and noticed the "Futaba" light on the TX was flashing, I turned off the TX and power it back on, that is when I got the mis-matched error messege. At this point, I am thinking the TM-14 module might be toast, I don't have another one to test. My concern is how this happened, if the TX is too closed to the RX, would it cause this problem?
SHARE  PM  EMAIL  Attn:RR  Quote
02-24-2010 08:38 PM  10 years ago
bbaxter

rrApprentice

Central Illinois

MyPosts All Forum Topic
Try taking out the module and then reinstall it. Make sure it's well-seated in the transmitter. Sometimes, that's it...it gets jarred and then isn't making good contact.

If that doesn't work, then the problem could be in the module or in the transmitter. It could be a software issue or hardware. No way to tell until we can see it. It will need a trip to the service center.
SHARE  PM  EMAIL  Attn:RR  Quote
11-22-2011 04:29 AM  9 years ago
mjorge

rrApprentice

Rio de Janeiro ,RJ - Brazil

MyPosts All Forum Topic
The module ONLY runs with the same region as the TX native is.

The 2,4 GHz module is not FREE Region.

For this above issue we have a 14MZ EUROPE Area native (35 MHz # Ch 69) And a new 2,4 GHz AMERICAN module.
The system displays "Mismatched RF-Module"
A local Futaba Assistence do it for you for just a little bucks.

Thus, the system will match perfecly on your present needs.

Good Luck and keep walking.
Mario Jorge, Rio de Janeiro - Brazil
SHARE  PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
11-22-2011 04:36 AM  9 years ago
Clarence Creer

rrVeteran

Fort Worth, Texas

MyPosts All Forum Topic
What made you revive this thread? I hope that he wasn't waiting almost 2 years for a replyTeam Kontronik Team minicopter/PeakAircraft
VTeam EvoPowerBattery
SHARE  PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
11-23-2011 03:28 PM  9 years ago
mjorge

rrApprentice

Rio de Janeiro ,RJ - Brazil

MyPosts All Forum Topic
I agree, but somebody sent me a PM.

Tks for your att.

Bye for now.
Mario Jorge, Rio de Janeiro - Brazil
SHARE  PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
WATCH
 1 page 3268 views Post Reply
HomeRC & Power✈️Aircraft🚁HelicopterRadio - Futaba FASST › Mismatched RF-Module -- Futaba 14MZ
Print TOPIC

 3  Topic Subscribe

Saturday, November 28 - 2:39 am - Copyright © 2000-2020 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online