RunRyder RC
WATCH
 1 page 507 views POST REPLY
HomeAircraftHelicopterAlignT-REX 600N › 600LE Head Setup- are factory link lenghts way off?
02-07-2010 11:35 AM  8 years agoPost 1
KingJoeMack

rrVeteran

New Baltimore, Mi USA

My Posts: All  Forum  Topic

Set up head (links)on bench according to factory specs.
Orignal setup, swash not centered.

To get swash to center of travel, I am near the end of my links that go from servo arms to swash.

With pitch at 0 in idle up (curve 0,50,100) Servo arms stright, ATV 100/100 for Pitch/elv/alie, Swash mix 60/60/60, no subtrim, no adjusting trim.

Went thro rest of head, and all I can get is 12/12 Collective pitch.

If this is how it is, I am going to change out servo to swash links on 600le with servo/swash links from 700. At least I will a lot of threads in the link.
Anybody have the same problem?

Fly with scheduled ground contact !

PM  EMAIL  GALLERY  Attn:RR  Quote
02-07-2010 12:53 PM  8 years agoPost 2
Andy from Sandy

rrElite Veteran

Bedfordshire, UK

My Posts: All  Forum  Topic

If you have had to make the aileron links much longer all I can think to ask is to double check you have screwed the elevator link all way on as that is fixed length in the A arm.

PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 507 views POST REPLY
HomeAircraftHelicopterAlignT-REX 600N › 600LE Head Setup- are factory link lenghts way off?
 Print TOPIC  Make Suggestion 

 0  Topic Subscribe

Monday, July 16 - 1:51 pm - Copyright © 2000-2018 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online