RunRyder RC
WATCH
 1 page 499 views POST REPLY
HomeAircraftHelicopter
e-
Scorpion Electric Components
› Problem w/ Scorpion 45 Amp Esc
02-07-2010 12:49 AM  8 years agoPost 1
mdlott

rrNovice

Newnan, GA

My Posts: All  Forum  Topic

Help please.

Just rebuilt my 450 after a crash
and replaced the ESC w/ a new unit as it was damaged in the crash. The ESC is the Commander 45amp and the motor is the -6 w/ 11 tooth pinion.

The problem I'm having is that I am unable to achieve a consistent full throttle headspeed. This is in normal mode w/ linear throttle curve. Soft start works properly and when I bench test w/ no blades, full throttle yields only 70% to 80% headspeed. If I reduce throttle to half or less and go immediately back to full, (pumping the throttle), I can achieve 100% head speed. In short, full throttle stick position does not always yield 100 percent headspeed.

I've tried reprogramming back to factory defaults, but no luck. The ESC I used before the crash (identical) worked perfectly w/ no programming right out of the box.

Any ideas would be greatly appreciated.

Thanks in advance.

PM  EMAIL  Attn:RR  Quote
02-07-2010 05:08 AM  8 years agoPost 2
kcordell

rrElite Veteran

O Fallon, MO

My Posts: All  Forum  Topic

Don't use it in governor mode, just use the soft start, then set your idle curve at 100% straight across.

Team Futaba, Team Synergy/Rail, Team Scorpion, Team Castle Creations, YS Engines, VelTye

PM  EMAIL  GALLERY  Attn:RR  Quote
02-07-2010 02:27 PM  8 years agoPost 3
mdlott

rrNovice

Newnan, GA

My Posts: All  Forum  Topic

Thanks for the reply.

I didn't think I was in gov mode as I returned to factory settings which should have inhibited governor mode. When I program SS = 1, my linear normal curve seems really weak and it doesn't want to go to full throttle. (Maybe I'm not giving it enough time) I'll try to activate SS again and set a flat throttle curve.

Any other ideas?

PM  EMAIL  Attn:RR  Quote
02-09-2010 04:12 AM  8 years agoPost 4
mdlott

rrNovice

Newnan, GA

My Posts: All  Forum  Topic

Bump, Anyone?

PM  EMAIL  Attn:RR  Quote
02-09-2010 05:43 AM  8 years agoPost 5
Zaneman007

rrElite Veteran

Texas - USA

My Posts: All  Forum  Topic

Did you do the initial set up for the Tx throttle to 100%.

Old Guys Rule!

PM  EMAIL  GALLERY  Attn:RR  Quote
02-09-2010 03:22 PM  8 years agoPost 6
mdlott

rrNovice

Newnan, GA

My Posts: All  Forum  Topic

Yes, sure did. About 15 times.

I reset normal throttle curve to 0, 25, 50, 75, 100 (linear)
and used IR receiver to reset the ESC to factory defaults. The other identical unit this replaced was set to factory defaults and always performed flawlessly. (Until the crash).

I don't know that it matters, but I did rebind after set up.

Idle up is currently at 75% flat and switching between normal and idle up @ full throttle doesn't always yield a change in headspeed. (Normal should increase head speed as it is currently 100% @ full collective.)

I'm stumped.

Thanks for the reply.

PM  EMAIL  Attn:RR  Quote
WATCH
 1 page 499 views POST REPLY
HomeAircraftHelicopter
e-
Scorpion Electric Components
› Problem w/ Scorpion 45 Amp Esc
 Print TOPIC  Make Suggestion 

 2  Topic Subscribe

Friday, July 20 - 1:42 pm - Copyright © 2000-2018 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online