RunRyder RC
WATCH
 1 page 692 views POST REPLY
HomeAircraftHelicopter
e-
Align
T-REX 450 › Trex 450 Pro - Main Head not working fine
01-25-2010 02:03 AM  8 years agoPost 1
cyberfox78

rrApprentice

Brazil

My Posts: All  Forum  Topic

Hi my friends,

Today a start the assembly of my new t-rex 450 pro.

After assembly all parts of mainhead, the movements of swashplate for ciclic (aileron and elevator) are not smoth as my other t-rex.

It´s a little hard to make the movements.

I tested on my T-Rex 600 and the movements are very smoth with no need to put some extra force

I tried to open a little the hole of ball links, loosen the arm bolts but still hard to make de movements

Can anybody help me?

Thanks

PM  EMAIL  GALLERY  Attn:RR  Quote
01-25-2010 04:08 AM  8 years agoPost 2
michael88997

rrElite Veteran

Lewisville,Tx

My Posts: All  Forum  Topic

Did u narrow it down the where, possibly locktight on a bearing

PM  EMAIL  GALLERY  Attn:RR  Quote
01-25-2010 04:54 AM  8 years agoPost 3
knightofcarnage

rrElite Veteran

chicago

My Posts: All  Forum  Topic

are you links stiking?

PM  EMAIL  GALLERY  Attn:RR  Quote
01-25-2010 11:08 AM  8 years agoPost 4
cyberfox78

rrApprentice

Brazil

My Posts: All  Forum  Topic

The swashplate movements up and down (pitch) are perfect.
The only problem is ciclic movements

I thought about loct tite in any bearing, but i remove and check

But its possible to have loctite inside.

What can i do?

PM  EMAIL  GALLERY  Attn:RR  Quote
01-25-2010 02:28 PM  8 years agoPost 5
michael88997

rrElite Veteran

Lewisville,Tx

My Posts: All  Forum  Topic

Pop all the links off and move everything by hand to narrow it down, alot of times it's just one sticky arm so once you figure out what isn't moving freely then you will know

PM  EMAIL  GALLERY  Attn:RR  Quote
01-25-2010 02:32 PM  8 years agoPost 6
Steff Giguere

rrProfessor

St-Eustache, Quebec, Canada

My Posts: All  Forum  Topic

After checking all the bearings try rimming the links, on the 450 pro they are tighter than the usual Align products.

Team Synergy, Rail blades, Team Scorpion, V-Team

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
01-25-2010 04:59 PM  8 years agoPost 7
cyberfox78

rrApprentice

Brazil

My Posts: All  Forum  Topic

I Tried to isolate the problem.
So, i remove part by part, checking everything.

Its look like the problem is on the seesaw, the movement of flybar its not so good.

The arms are ok
The link are ok

anything can be done in the seesaw?

PM  EMAIL  GALLERY  Attn:RR  Quote
01-25-2010 05:32 PM  8 years agoPost 8
michael88997

rrElite Veteran

Lewisville,Tx

My Posts: All  Forum  Topic

Most likely a bearing has locktight or a part does.... Try finding the part that's stopping it up and try to work that part free

PM  EMAIL  GALLERY  Attn:RR  Quote
01-25-2010 06:38 PM  8 years agoPost 9
luca bianchessi

rrApprentice

bergamo, italy

My Posts: All  Forum  Topic

even my head is not very smooth when it's VERYcold outside. even the flybar is not fluent......

PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 692 views POST REPLY
HomeAircraftHelicopter
e-
Align
T-REX 450 › Trex 450 Pro - Main Head not working fine
 Print TOPIC  Make Suggestion 

 3  Topic Subscribe

Monday, August 20 - 9:58 am - Copyright © 2000-2018 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online