RunRyder RC
 2  Topic Subscribe
WATCH
 1 page 498 views POST REPLY
HomeAircraftHelicopterRadio - Servo - Gyro - Gov - Batt › Align 610 servo NIB
01-25-2010 12:52 AM  8 years agoPost 1
solo

rrApprentice

San Antonio Tx, USA

My Posts: All  Forum  Topic

I recently purchased 4 Align 610 servos within the last month. I installed them in my Hirobo 50 HPM. Three of the servos sound good when you turn the servo horn by hand. The forth servo sounds as if the gears are bad; It feels gritty, screechie not as smooth as the other three. Did not want to open it and void warranty. I have not plugged them up in the receiver yet. Just wondering if I should return it. Got them all from Hobby Hut. Has anyone ever expirenced this with new Align servos?

PM  EMAIL  GALLERY  Attn:RR  Quote
01-25-2010 01:03 AM  8 years agoPost 2
psych-lick

rrKey Veteran

Portland, OR

My Posts: All  Forum  Topic

Almost all of my 610's were like this when new. I just used them anyway. You cannot notice any difference when powered up.

I don't know if mine are still like this after using them for awhile (I don't really move them by hand anymore). Perhaps they just need to get broken in..

-Jeff T.

PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 498 views POST REPLY
HomeAircraftHelicopterRadio - Servo - Gyro - Gov - Batt › Align 610 servo NIB
 Print TOPIC  Make Suggestion 

 2  Topic Subscribe

Sunday, June 24 - 8:13 am - Copyright © 2000-2018 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online