RunRyder RC
WATCH
 1 page 403 views POST REPLY
HomeAircraftHelicopter
e-
Electric Motors-Controllers-ESC
Other › 600L getting hot
01-15-2010 01:46 AM  8 years agoPost 1
cctvflyer

rrNovice

Lancaster, CA

My Posts: All  Forum  Topic

I have been flying my 600CF for a while, about 50 flights, no problems. This past Saturday, after 2 flights, I landed and the motor had a very strong burnt electronics smell. Don't notice any power loss, but the motor is suddenly getting hotter than it ever did before. Any ideas?
Thanks

PM  EMAIL  GALLERY  Attn:RR  Quote
01-15-2010 09:10 AM  8 years agoPost 2
MrMel

rrProfessor

Gotland

My Posts: All  Forum  Topic

Shot bearings is the usual suspect.

Gone fishing..or hunting..or something
My site: http://heli.dacsa.net - VBar videos and more

PM  EMAIL  GALLERY  Attn:RR  Quote
01-15-2010 10:08 AM  8 years agoPost 3
naked painter

rrVeteran

Mid glamorgan uk

My Posts: All  Forum  Topic

Do you fly back to back to back with the lipos or do you let the motor cool down between flights?

PM  EMAIL  Attn:RR  Quote
01-15-2010 05:26 PM  8 years agoPost 4
cctvflyer

rrNovice

Lancaster, CA

My Posts: All  Forum  Topic

When I first got
the heli, I could fly as many packs as I wanted, with no delay between flights, motor would get just a bit warm. Now all of a sudden, after just one flight it gets very hot.

I'm thinking I have to replace the motor, everything I have been reading says the Align motors don't rebuild very well.

PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 403 views POST REPLY
HomeAircraftHelicopter
e-
Electric Motors-Controllers-ESC
Other › 600L getting hot
 Print TOPIC  Make Suggestion 

 2  Topic Subscribe

Monday, July 16 - 4:22 am - Copyright © 2000-2018 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online