RunRyder RC
WATCH
 1 page 492 views POST REPLY
HomeAircraftHelicopter
e-
Align
Other › align 450 problems
01-14-2010 04:58 AM  8 years agoPost 1
bhoff

rrVeteran

houston texas

My Posts: All  Forum  Topic

when i get ready to fly, everything plugged in..i put a little elevator and blades turn about 3 times then as i keep going to mid stick it just stops..do any of you happen to know anything about that?

PM  EMAIL  GALLERY  Attn:RR  Quote
01-14-2010 05:09 AM  8 years agoPost 2
george0079

rrElite Veteran

USA

My Posts: All  Forum  Topic

ESC programming would be my first guess.

Hell... I can fix that.
Uh oh..
Nope.
It's ***ked!!!
RE-KIT!!!!!

PM  EMAIL  GALLERY  Attn:RR  Quote
01-15-2010 01:33 PM  8 years agoPost 3
bopshi

rrApprentice

greenport ny

My Posts: All  Forum  Topic

Went to fly today and my heli is doing same. tried 2 different batteries. Temp was @30. I have a cheapo hdx motor with at least 70 flts on it and 2.5 year old 35 amp alighn esc. So my guess is either speed control is shot or motor doesnt like cold weather. It worked fine last week indoors. Will test later when it warms up. Dave

PM  EMAIL  Attn:RR  Quote
01-15-2010 07:48 PM  8 years agoPost 4
bhoff

rrVeteran

houston texas

My Posts: All  Forum  Topic

got it..my esc wire was too close and touching my esc now it works

PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 492 views POST REPLY
HomeAircraftHelicopter
e-
Align
Other › align 450 problems
 Print TOPIC  Make Suggestion 

 1  Topic Subscribe

Wednesday, July 18 - 3:22 am - Copyright © 2000-2018 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online