RunRyder RC
 4  Topic Subscribe
WATCH
 1 page 664 views POST REPLY
HomeAircraftHelicopter
e-
Mikado
Logo 600 › Logo 600, linkages are not level when using futaba servos...V bar.
10-21-2009 05:31 PM  8 years agoPost 1
saitoflyer

rrVeteran

L.A. CA

My Posts: All  Forum  Topic

this is the first time building a logo w/ futaba servos, and noticed that the linkages are not 90degrees from the side and the back. They are slightly off. I used servos spacers and Mikado servo arms. they are perfectly distanced just like the manual. When I installed Hitecs this was perfect. Elev. servo is off too.. does anyone else have this problem?

is that a new heli? Oh no honey, its the same one w/different stickers.....

PM  EMAIL  GALLERY  Attn:RR  Quote
10-21-2009 07:03 PM  8 years agoPost 2
OICU812

rrMaster

Edson, Alberta, Canada

My Posts: All  Forum  Topic

you mean like height? don't understand here...use the subtrim in software for each individual servo to achieve 90 degrees. I am running 3 machines with BLS451s at moment.

...Once upon a time there were Nitros, flybars and frequency pins...

PM  EMAIL  GALLERY  Attn:RR  Quote
10-21-2009 09:31 PM  8 years agoPost 3
helicraze

rrElite Veteran

Victoria - Australia

My Posts: All  Forum  Topic

Don't worry its not an issue, futaba is what mikado recommends.

Only use the spacers on the aileron servos and not elevator!

I found that to level the swash i had to turn in the front links and turn out the elevator links to get swash level with arms at 90.

PM  EMAIL  GALLERY  Attn:RR  Quote
10-21-2009 11:13 PM  8 years agoPost 4
SGrim80

rrVeteran

Lehigh Valley, PA

My Posts: All  Forum  Topic

I thought I read somewhere that the elevator link should be 2 turns out from the aoleron links but don't quote me on that. It certainly wasn't a Mikado "spec" either.

Can anyone chime in?

PM  EMAIL  GALLERY  Attn:RR  Quote
10-21-2009 11:44 PM  8 years agoPost 5
helicraze

rrElite Veteran

Victoria - Australia

My Posts: All  Forum  Topic

Yes that was a post from me. But i guess to keep things even its better to wind in the front aileron and out on the elevator.

PM  EMAIL  GALLERY  Attn:RR  Quote
10-22-2009 03:48 AM  8 years agoPost 6
SGrim80

rrVeteran

Lehigh Valley, PA

My Posts: All  Forum  Topic

I'm pretty certain it was a sticky on the other forum.

PM  EMAIL  GALLERY  Attn:RR  Quote
10-22-2009 09:44 AM  8 years agoPost 7
OICU812

rrMaster

Edson, Alberta, Canada

My Posts: All  Forum  Topic

Hmm my distance on all my 3 servo to swash rods are same, I didn't shorten or lengthen any, heck maybe I should have but I just got em all even, put on the swash tool and adjusted in software, lol. I'll have to take a closer look even myself now!

...Once upon a time there were Nitros, flybars and frequency pins...

PM  EMAIL  GALLERY  Attn:RR  Quote
10-22-2009 04:01 PM  8 years agoPost 8
SGrim80

rrVeteran

Lehigh Valley, PA

My Posts: All  Forum  Topic

Ha, helicraze, it WAS you! Its your sticky LOL.

PM  EMAIL  GALLERY  Attn:RR  Quote
10-22-2009 10:06 PM  8 years agoPost 9
helicraze

rrElite Veteran

Victoria - Australia

My Posts: All  Forum  Topic

Well i found if all were even length and all arms at 90 the swash was not level, it had to move as if giving forward elev.

I do not think its big deal as vbar will take care of any interactions in flight etc

PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 664 views POST REPLY
HomeAircraftHelicopter
e-
Mikado
Logo 600 › Logo 600, linkages are not level when using futaba servos...V bar.
 Print TOPIC  Make Suggestion 

 4  Topic Subscribe

Sunday, June 24 - 10:19 am - Copyright © 2000-2018 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online