RunRyder RC
 5  Topic Subscribe
WATCH
 1 page 561 views POST REPLY
HomeAircraftHelicopter
e-
Align
T-REX 250 › Problem with new weighted tailblade holders
10-20-2009 04:15 AM  8 years agoPost 1
Benth

rrApprentice

New London Ct

My Posts: All  Forum  Topic

Ive got a original 250 that i just installed the Limited Edition Silver 250SE head and the 250SE tail housing and tailblade grips. So on the first flight I had a really bad tail wag it was uncontrolable. I tried messing with the setting on the gyro and ball placement on the servo horn but nothing would correct it. I put the original tailblade grips on and it flies great now. Anybody else have a problem with the tailblade grips that have the little weights on them(H25095A)? I have a Futaba GY520 and am using Hitec HS5065MG for all 4 servos. Why did they put the weighs on the grips anyways what do they do?

PM  EMAIL  GALLERY  Attn:RR  Quote
10-20-2009 04:54 AM  8 years agoPost 2
vigor1

rrNovice

Dallas, TX - USA

My Posts: All  Forum  Topic

I'm a heli newbie, but I think you need to reduce your gain if you are using the new tailblade grips until you stop getting wag. I guess the new tailgrips offload some work from your tail servo.

PM  EMAIL  Attn:RR  Quote
10-20-2009 05:00 AM  8 years agoPost 3
Benth

rrApprentice

New London Ct

My Posts: All  Forum  Topic

Thanks vigor but I did try that. I had the gain all the way down and it still did it. Just to explain the tail would randomly dart back and forth 6-8 inches. This was no small wag. Strangly if I went into fast forward flight and like did a loop it was fine until I tried to hover.

PM  EMAIL  GALLERY  Attn:RR  Quote
10-20-2009 05:58 AM  8 years agoPost 4
knightofcarnage

rrElite Veteran

chicago

My Posts: All  Forum  Topic

Well if your using stock gyro then add delay to and lower some gain.

PM  EMAIL  GALLERY  Attn:RR  Quote
10-20-2009 07:17 AM  8 years agoPost 5
DKTek

rrVeteran

Melbourne, FL-USA

My Posts: All  Forum  Topic

I have a Futaba GY520 and am using Hitec HS5065MG for all 4 servos.

The beatings will continue until morale improves...

PM  EMAIL  GALLERY  Attn:RR  Quote
10-20-2009 09:11 AM  8 years agoPost 6
pseudonym

rrApprentice

Edmonton, Alberta

My Posts: All  Forum  Topic

Turn off the Governor. I have had issues as have others. It seems that the align governor can cause some rather bad tail wag. You may also want to swap out your tail servo for a JR DS290G or the like. At .06 they are considerably faster than the hitech you are currently using for the tail. You definatly don't need such a high torque servo on the 250. Resolution is, by far, a more important issue.

I am not sure why you aren't having issues with the old tail.. I am using the "Chinese Tail Mod" myself to try and cut down on the wag. Still have some vibration that I can't get rid of because of the slop in the stock tail. My microheli tail should be ariving soon so I can tell you if that makes a difference or not in about a week.

Other than that.. make sure your ball placement is absolutly as close as you can to the centre of your servo horn. Currently I have mine at 4.8mm from centre.

Last thing you want to check is for any binding issues with the tail. Is it getting caught or stuck anywhere? Don't forget to add some grease to insure the collar moves freely.

Those would be my suggestions.

I am using the same gyro as you and a Futaba 10 channel radio. I have 10% avs gain in GY mode.

Hope that helps!

unspelling the world one misprint at a time.

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
10-20-2009 11:17 AM  8 years agoPost 7
Richardmid1

rrProfessor

Leeds, England

My Posts: All  Forum  Topic

I too am not a fan of this weighted tail grip business! I had the old 250 and the tail was solid! I now have the new SE and the tail is not as solid! A while back I tried weighting my 450's tail grips and had to lower the gain right down to reduce the wag! I took them damn weights straight off!

60% of the time, it works every time!

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
10-20-2009 01:42 PM  8 years agoPost 8
Benth

rrApprentice

New London Ct

My Posts: All  Forum  Topic

I dont use the govenor. Ive been thinking of installing a Jr 3500G tail servo I know its a little big but it works sweet on my Rave with this gyro. I have gone thru and looked for binding and really its very smooth I tried installing shims in between the grips and tail blades which does remove a little slop but did not fix the big wag. I measured the distance to the ball on the servo horn and its just a hair under 5mm so that should be fine. Thanks for the advice guys

PM  EMAIL  GALLERY  Attn:RR  Quote
10-20-2009 02:23 PM  8 years agoPost 9
Richardmid1

rrProfessor

Leeds, England

My Posts: All  Forum  Topic

I think your main problem is that tail servo your using, try JR 290G, Robbe FS 61 BB, Hyperion Atlas DS11-GCB, INO-LAB HG-D201HB or even the stock Align DS420 tail servo. There are plenty of micro tail servo options without going to a more expensive Mini servo which is going to add weight to an already low power to weight ratio model.

60% of the time, it works every time!

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
WATCH
 1 page 561 views POST REPLY
HomeAircraftHelicopter
e-
Align
T-REX 250 › Problem with new weighted tailblade holders
 Print TOPIC  Make Suggestion 

 5  Topic Subscribe

Monday, June 25 - 6:51 pm - Copyright © 2000-2018 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online