RunRyder RC
WATCH
 1 page 594 views Post Reply
Home✈️Aircraft🚁HelicopterHelicopter Main Discussion › damn...now my governer seems to be crappin out!
09-19-2009 07:21 PM  11 years ago
Topic Vote0Post 1
bcrector

rrNovice

muncie, IN

MyPosts All Forum Topic
damn...now my governer seems to be crappin out!
Just this Friday I got a new gy401 and 9254 servo from futaba ...they said a sensor in the gyro I sent them was bad and offered a new gyro and servo for $160 so I agreed. I go out to the field with my other heli this morning and after about an hour of trying to get the GV-1 to govern I gave up. The sensor is showing 98% signal, the rpm indicator is matching up with my hand held tach and the unit is switching on but will not override transmitter imput. I tried various throttle curves and reset throttle limits and rpm limits to no avail. I noticed the last few flights that it seemed to sometimes let the motor speed up when collective was decreased...now it flat out wont work. The gyro was relatively new and this governor is even newer...maybe 2 gallons of use if that. I can understand servos failing due to moving parts and constant abuse but governors and gyros with no moving parts???? Is there something silly that I keep overlooking or what?
SHARE  PM  EMAIL  Attn:RR  Quote
09-19-2009 07:31 PM  11 years ago
LonR

rrElite Veteran

Macomb,Mi

MyPosts All Forum Topic
Maybe the sensor is bad,did you try to change it or adjust it?Try the Spektrum backplate sensor,it works awesome .If it ends up being the GV1 and you get the throttle jockey Revmax,the Spektrum backplate sensor works awesome with it too so your not just throwing money away.600LE,OS55,OS PowerBoost pipe,Align 610's,Spartan
SHARE  PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
09-19-2009 07:48 PM  11 years ago
TankDirt

rrKey Veteran

Illinois

MyPosts All Forum Topic
I say its the servo..your story sounds like it slowly and intermittently started going bad...I dont belive the GV1 can use the Spektrum backplate sensor. But it would be great if you had just about any other govenor.

EDIT..did some research..you can use it with the GV-1 but you need to add a resistor.. See this thread

http://www.runryder.com/t469186p1/?...Spectrum+sensor
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
09-19-2009 08:00 PM  11 years ago
Sonic88

rrVeteran

Murfreesboro, TN

MyPosts All Forum Topic
I believe that you must use a modified backplate sensor to work with the GV1. These guys make an adapter.
http://www.alumafx.com/webstore/

Just scroll down to the GV1 to Specktrum Sensor Adapter.

Costs 11.50
Procrastinators of the world unite ... tomorrow.
AMA #: 912822
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
10-09-2009 03:00 PM  11 years ago
bcrector

rrNovice

muncie, IN

MyPosts All Forum Topic
UPDATE: it turned out to be the servo oddly enough. I swaped out the GV1 with a Throttle Max and the same thing happened. I then swaped in a new 3151 servo and it works perfectly now.
SHARE  PM  EMAIL  Attn:RR  Quote
10-09-2009 05:17 PM  11 years ago
TankDirt

rrKey Veteran

Illinois

MyPosts All Forum Topic
Sweet..Glad you got it going..now go fly that bad boy
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 594 views Post Reply
Home✈️Aircraft🚁HelicopterHelicopter Main Discussion › damn...now my governer seems to be crappin out!
Print TOPIC

 3  Topic Subscribe

Wednesday, January 20 - 3:42 am - Copyright © 2000-2021 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online