RunRyder RC
WATCH
 1 page 1599 views Post Reply
HomeRC & Power✈️Aircraft🚁HelicopterRadio - Servo - Gyro - Gov - Batt › CSM SL720 - Futaba GV-1 & DSX9 (X9303?) problems
09-14-2009 09:45 PM  11 years ago
Topic Vote0Post 1
gramey

rrApprentice

United Kingdom

MyPosts All Forum Topic
CSM SL720 - Futaba GV-1 & DSX9 (X9303?) problems
I recently changed from a DX7 to a JR DSX9,I think it's called a X9303 stateside, 2.4Ghz TX with the JR 9 channel RX. I did this to give me the extra channels needed to be able to have a seperate on off switch for the GV-1 and a seperate channel to plug my Jewel generator into.
According to the instructions for the TX I should plug my GV-1 into the gear channel and the gain for my gyro, a CSM SL720, into the Aux 2 channel. The gear channel is the dedicated governor channel, the Aux 2 cmoes up showing gyro. The GV-1 appears to function as expected when plugged into the gear channel but the gyro does not appear to be recognised in Aux.2
On my other heli's I have the JR770 gyro which has a single wire for the gain whereas on my Spectra the CSM has a 3 wire lead for the gain which also presumbaly incorporates the Quick Set function?
The problem is with the CSM plugged into the Aux 2 channel, despite it showing gyro below Aux 2 in Device Select, the rudder does not work and I none of the switches will activate the gyro set up.
Can anyone help with this problem, I've temporarily put the gyro gain back in the gear channel and the governor in Aux 2 but now I cannot switch the governor off without setting the head speed in Normal to 999.
Sorry about the long post but any help is gratefully appreciated.
Dumb thumb specialist
SHARE  PM  EMAIL  Attn:RR  Quote
09-15-2009 06:12 AM  11 years ago
carcrasher

rrElite Veteran

east coast

MyPosts All Forum Topic
you need to have you gain in AUX 2 set higher than 60% otherwise it will not enter the quick set-up. what servo are you using with it? If it's a 92251/56 or a bls251 it won't work since you have to go into the quick set-up to change it to 760.
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
09-15-2009 11:39 AM  11 years ago
gramey

rrApprentice

United Kingdom

MyPosts All Forum Topic
Tail servo is a JR 8900, I'm beginning to think I should have just bought another 770 instead of listening to the guy in my LHS who said how great this gyro is supposed to be.Dumb thumb specialist
SHARE  PM  EMAIL  Attn:RR  Quote
09-15-2009 05:35 PM  11 years ago
carcrasher

rrElite Veteran

east coast

MyPosts All Forum Topic
I too have heard great things about this gyro. I have yet to experience any of it. This gyro doesn't seem to like small servos and works best with fast servos, 8900 9256 and etc. the problem I've had with it is I'm trying to get it to work on my t500 with no luck. I've heard the 770 has it's issues also. I'm sure once you get it sorted out it will be fine. did you set the gain in AUX2 to 60% or higher? I think 100% is best. did you confirm this with the servo monitor screen? when you flick the switch it should move from +100 to -100%, that's what gets you into the quick set-up.
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
09-16-2009 12:38 AM  11 years ago
gramey

rrApprentice

United Kingdom

MyPosts All Forum Topic
I put the screen on Monitor and flicked every switch on the TX with the gyro plugged into Aux 2 but I couldn't see any indication that any of these switches were doing anything connected with the gyro. The servo would flick when you first powered it on but there was no movement at all when you moved the rudder stick. I know it's not the servo as when I revert the gyro to the Gear channel I can get into the quick set up and the servo moves as it should.Dumb thumb specialist
SHARE  PM  EMAIL  Attn:RR  Quote
09-16-2009 08:14 AM  11 years ago
plantone

rrVeteran

Perth wa

MyPosts All Forum Topic
Im using a csm 720 with the 9256 but have changed the gears to 9257 gear set on a Trex 500 & it flies great. Its a damn good gyro stick with it you will be glad you did. Sorry cant help much im using a 14 mz with spectrum module. Have you tried telling aux 2 its aux 2 instead of gyro & then use the atv to adjust your gain & set that to about 80 & 20?? hope that makes sense.Mongoose
Srimok FAI
SAB Goblin
ENV Rave Next D 450
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
09-17-2009 12:54 AM  11 years ago
gramey

rrApprentice

United Kingdom

MyPosts All Forum Topic
Thanks for that I've now got it so that Aux 2 recognises the gyro and got it set up, just got to sort out a minor issue with the governor now.
Thanks for the advice people.
Dumb thumb specialist
SHARE  PM  EMAIL  Attn:RR  Quote
09-17-2009 11:12 AM  11 years ago
carcrasher

rrElite Veteran

east coast

MyPosts All Forum Topic
I finally got mine to work also. I want to take it up and do the quick trim and see what the gyro can take.
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 1599 views Post Reply
HomeRC & Power✈️Aircraft🚁HelicopterRadio - Servo - Gyro - Gov - Batt › CSM SL720 - Futaba GV-1 & DSX9 (X9303?) problems
Print TOPIC

 2  Topic Subscribe

Monday, January 18 - 2:10 pm - Copyright © 2000-2021 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online