RunRyder RC
 1  Topic Subscribe
WATCH
 1 page 369 views TOPIC CLOSED
HomeAircraftHelicopterEngines Plugs Mufflers Fuel › OS 50 cuts out at mid power
01-18-2009 11:59 PM  9 years agoPost 1
Jerc 77

rrApprentice

Minot

My Posts: All  Forum  Topic

I searched for this, but I can't find the answer. Here's my set up:
OS 50 SX-H with about 2 gallons through it
OS LC 3 Hot plug- same as I've always used
Cool Power 30%- same as always
Throttle curves have not changed
I live on Oahu, so the temp is relatively the same (give or take 15*)

I never had a problem with this heli until I put it into the ground in August. I rebuilt it, retuned it, and it has been nice to me ever since (we have a mutual agrrement with each other- she's nice to me, I buy her all the best parts and keep her clean). So, last week I took her out to clean out the cob webs and she started cutting out at about mid throttle. Only in the air though. I have only dared to hover her, since she started getting all PMSey on me.
I have put in a new plug, I have richened it, leaned it, pulled all the plumbing to make sure there is nothing blocking. I was thinking varnish, but I have run two tanks through and she still does it. Any thoughts?????? If I can't fix her- anyone want to trade a Raven 50 for a 600E?

"Everybody talks about the weather, but nobody does anything about it." - Mark Twain

PM  EMAIL  GALLERY  Attn:RR
01-19-2009 12:15 AM  9 years agoPost 2
airdodger

rrElite Veteran

Johnston USA

My Posts: All  Forum  Topic

Check the rear bearing for rust.

Chris

PM  EMAIL  GALLERY  Attn:RR
01-19-2009 12:17 AM  9 years agoPost 3
Jerc 77

rrApprentice

Minot

My Posts: All  Forum  Topic

Thanks
Thanks, I'll go pull the back plate now.

"Everybody talks about the weather, but nobody does anything about it." - Mark Twain

PM  EMAIL  GALLERY  Attn:RR
01-19-2009 12:37 AM  9 years agoPost 4
Helirat

rrApprentice

Michigan

My Posts: All  Forum  Topic

PM  EMAIL  GALLERY  Attn:RR
01-19-2009 09:31 AM  9 years agoPost 5
Jerc 77

rrApprentice

Minot

My Posts: All  Forum  Topic

Thanks
Well, I spent the day taking it apart, cleaning it, and putting it back together. I took it outside, checked it, yada yada yada, put fuel in the tank, and it wouldn't turn over! I took it back inside, ripped the engine back out, took the fan off, pulled the back plate, ensured everyting rotated fine, put it all back together and...viola! She runs like a whipped dog now! I think it had two problems:
1.) When it would cut out during a hover, I beilieve there was a particle in the injector in the carb throat.
2.) When it wouldn't turn over, I believe the fan itself, was hitting part of the cooling shroud.
Once I put it back together and started it, it ran better than it had in a long time.
Thanks guys for all your suggestions. I always appreciate the outpouring of advice when I ask a question on here. Thanks again.
Jeremy.

"Everybody talks about the weather, but nobody does anything about it." - Mark Twain

PM  EMAIL  GALLERY  Attn:RR
WATCH
 1 page 369 views TOPIC CLOSED
HomeAircraftHelicopterEngines Plugs Mufflers Fuel › OS 50 cuts out at mid power
 Print TOPIC  Make Suggestion 

 1  Topic Subscribe

Wednesday, June 20 - 3:16 am - Copyright © 2000-2018 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online