RunRyder RC
 2  Topic Subscribe
WATCH
 1 page 375 views POST REPLY
HomeAircraftHelicopter
e-
Align
T-REX 450 › T-Rex 450 SE V2 - Running Hot??
01-18-2009 07:14 AM  9 years agoPost 1
KarbonBird

rrKey Veteran

Australia

My Posts: All  Forum  Topic

I have got a stock SE V2 which I have added 325mm blades to as it will be used for aerial work. On testing it (without load) the motor started to give short power bursts as though it was running low on battery. I landed and the Outrage 2200 mAh battery was very hot and so was the motor and speed controller.

Any suggestions as to what is causing this?

PM  EMAIL  GALLERY  Attn:RR  Quote
01-18-2009 09:47 AM  9 years agoPost 2
what_the_helli

rrKey Veteran

cookeville, tn USA

My Posts: All  Forum  Topic

check your gear mesh..... I over looked it and I had the same issue once

I put the fun in dysFUNctional :)
Team KBDD & Funding by TnPrintMasters.com

PM  EMAIL  GALLERY  Attn:RR  Quote
01-18-2009 11:56 AM  9 years agoPost 3
Asid

rrVeteran

uk

My Posts: All  Forum  Topic

Also check the tail belt tension. If its too tight it will sap power.

Regards

If it ain't broke then break it.

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
01-18-2009 12:10 PM  9 years agoPost 4
KarbonBird

rrKey Veteran

Australia

My Posts: All  Forum  Topic

Thanks .. will check the belt & gear mesh.

PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 375 views POST REPLY
HomeAircraftHelicopter
e-
Align
T-REX 450 › T-Rex 450 SE V2 - Running Hot??
 Print TOPIC  Make Suggestion 

 2  Topic Subscribe

Wednesday, June 20 - 2:11 pm - Copyright © 2000-2018 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online