RunRyder RC
 2  Topic Subscribe
WATCH
 1 page 496 views POST REPLY
HomeAircraftHelicopterRadio - Spektrum DSM › AR700 no governor problems
01-13-2009 07:23 PM  9 years agoPost 1
spike2450

rrNovice

cornwall, england

My Posts: All  Forum  Topic

Hi DX7 AR7000 and align Gov

Had another crash this 3D can be expensive!!

Rebuilt the heli and all works ok except there is no response from the Align Gov.

Light stays green at all times and turns off with magnet but doesn't respond to the gear switch.

Intermittent throttle travel when using other controls i.e. cyclic and pitch, same movement on the throttle as if you had interference.

Plug throttle servo directly into throttle channel on receiver and servo works fine.

Tried putting Gov into aux 2 route and same i.e. no response from servo and gov light just stays green.

Thoughts were broken receiver but gyro on Aux 2 works fine.

New Align gov and still same.

Servo screen on DX7 working as it should.

Any thoughts, i've searched and one thing i will try is to bind again with all servo leads removed.

Any thoughts are appreciated.

PM  EMAIL  Attn:RR  Quote
01-13-2009 10:09 PM  9 years agoPost 2
AAKEE

rrApprentice

Boden, Sweden

My Posts: All  Forum  Topic

I know somebody had a problem(was posted here on RR) with that the syncronized servo outputs made his gov unable to detect the signal on the channel used for guiding the gov. (dont remember brand, but at least not revlock).
That gov couldnt handle the fact that the different channels arrived the same time. If I remember it right he used another channel (ie AUX2 instead of GEAR or vice versa) to solve the problem.

Should be found here on RR, if the right search words are used...?

PM  EMAIL  Attn:RR  Quote
WATCH
 1 page 496 views POST REPLY
HomeAircraftHelicopterRadio - Spektrum DSM › AR700 no governor problems
 Print TOPIC  Make Suggestion 

 2  Topic Subscribe

Monday, June 18 - 10:30 pm - Copyright © 2000-2018 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online