RunRyder RC
 10  Topic Subscribe
WATCH
 3 pages [ <<    <    ( 1 )     2      3     NEXT    >> ] 3569 views POST REPLY
HomeAircraftHelicopter
e-
Align
T-REX 500 › What now??
03-10-2008 02:23 AM  10 years agoPost 1
hrosee

rrApprentice

Richardson, Texas

My Posts: All  Forum  Topic

Three of us went flying today. Two of us have 500CF's. We both did the mods. Grounding the front and rear bearings and grounded the negative battery lead to the motor mount. Other than that we are both stock.

We are both using AR7000 receiver and I use a DX7 and the other guy uses a JR10X with the spektrum module.

We both took big hits and lost total control. My friend was up high enough where he regained control and landed. I was not so lucky. Mine did the chicken dance after it went in on it's side. I won't go into all the parts but it was a hundred dollar crash with the carbon blades.

We sprayed my friends heli with silicone spray and he flew 2 more 4 minute flights with no problems. It had been 2 weeks since he sprayed his and 3 weeks since I sprayed mine. This was only my 3rd flight. I had surgery right after I built mine and this was the first time to fly it.

So all you guys that have done the mods are you still spraying the belt?

Also I might mention that I took my tester with and there was just a little ac buildup on the tail blades on both of ours.

So, what now? Just keep spraying lube at the begging of each day? Tork tube, if and when it comes out? Or is there something else to try.

I had thought with the grounding that the silicone was not necessary.

Thanks for any comments.

2 - Raptor 50's V2

PM  EMAIL  GALLERY  Attn:RR  Quote
03-10-2008 02:30 AM  10 years agoPost 2
LoveMyTrex

rrVeteran

Hamilton,VA

My Posts: All  Forum  Topic

I believe the silicone is more effective and easier than the grounding, so why do it. just spray the belt and fly. then when the TT comes out put that in and don't worry.

600N 55HZ/SAB-55 600V's
700N 91HZ/SB-20 690V2 V's
90SG 91HZ/SB-20 710V2 V's

PM  EMAIL  GALLERY  Attn:RR  Quote
03-10-2008 02:34 AM  10 years agoPost 3
R38133

rrKey Veteran

USA

My Posts: All  Forum  Topic

Where is the TT????????????

PM  EMAIL  GALLERY  Attn:RR  Quote
03-10-2008 02:43 AM  10 years agoPost 4
3Dx

rrElite Veteran

Monterrey NL

My Posts: All  Forum  Topic

This is incredible....

I have a similar problem right now….

http://www.runryder.com/t415038p1/?p=3320518#RR

PM  EMAIL  GALLERY  Attn:RR  Quote
03-10-2008 02:45 AM  10 years agoPost 5
whyfly

rrVeteran

Temecula C.A.

My Posts: All  Forum  Topic

I heard there will be no TT thats why I did not pick one up yet....
Reading to many crash reports there is always pains with new helis.

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
03-10-2008 02:48 AM  10 years agoPost 6
3Dx

rrElite Veteran

Monterrey NL

My Posts: All  Forum  Topic

Jason told me last week that he is working on that......

Seems that we the customers are the research and development department of align, we pay, crash our helis so they learn….. And fix their problems!!! And after that they do business also with the new parts we need to buy!!

PM  EMAIL  GALLERY  Attn:RR  Quote
03-10-2008 02:56 AM  10 years agoPost 7
Helisonmymind

rrApprentice

Toronto, Canada

My Posts: All  Forum  Topic

brosee,

that sucks, I'm sorry to hear about your troubles. I don't have much to add since I only have a 450, but I wanted to chime in and wish you luck in solving this.

Helisonmymind: 450 Pro, 500ESP, 600ESP 8S, 600NSP, Quark SRB. ***Thanks RunRyder!!!***

PM  EMAIL  GALLERY  Attn:RR  Quote
03-10-2008 03:13 AM  10 years agoPost 8
dmkc929

rrApprentice

Illinois

My Posts: All  Forum  Topic

belt problems?????
Why has Raptor been flying belt heli's for years and no one ever claimed this issue ???? If it's gas or electric belt drive, it would still be an issue, correct ???? I'm just wondering what's the problem. Could it be something else besides 2.4 ?? How many people who have crashed have the align stock prats, motor, esc, etc ?? And are thier anyone who's using CC or jazz esc's crashing also.???? Just wondering here. I don't have a 500 but I have a 450Se and a 600E both on spektrum. I haven't flown the 600E yet this year but I've tried the 450Se with no problems.... Just wondering here...
Also, I follow the eraptor forums and no one has claimed this issue on 2.4 on either the 550e or the 620e......

PM  EMAIL  GALLERY  Attn:RR  Quote
03-10-2008 03:14 AM  10 years agoPost 9
STUPINEER

rrApprentice

allen tx

My Posts: All  Forum  Topic

this may be a stupid question.. are the people that are still on 72mh having the same problems that the 2.4 guy's are having???

If something hasn't broken on your helicopter, it's about to.'

PM  EMAIL  GALLERY  Attn:RR  Quote
03-10-2008 03:16 AM  10 years agoPost 10
hrosee

rrApprentice

Richardson, Texas

My Posts: All  Forum  Topic

I really don't know what else to do other than put it back together and fly it.

This crash killed my:

Carbon Blades
Tail Boom
2 sets of servo gears
main shaft
feather shaft
lost one link
main gear

I just about have it back together. If it weren't for the blades it wouldn't be so bad.

I may just park it until someome finds a real fix. I don't think the grounding does it in total. I have one of the home depot ac detectors and it really doesn't show anything wrong except off the main gear but I get that off my 450se and it flys fine.

I agree that Align is not doing their testing. I am building a 600N now and it had a couple of bad parts. I will think twice before I buy another Align product.

I'll fly it again tomorrow evening and see what happens.......

2 - Raptor 50's V2

PM  EMAIL  GALLERY  Attn:RR  Quote
03-10-2008 03:17 AM  10 years agoPost 11
hrosee

rrApprentice

Richardson, Texas

My Posts: All  Forum  Topic

Yes to the 72mhz. If you look at the other post for 3dx he is flying 72 mhz and had a similar problem.

2 - Raptor 50's V2

PM  EMAIL  GALLERY  Attn:RR  Quote
03-10-2008 03:21 AM  10 years agoPost 12
hrosee

rrApprentice

Richardson, Texas

My Posts: All  Forum  Topic

As a side not I fly Spektrum on all 7 of my Heli's and on 7 planks and never had a problem except on this 500cf.

What kills me is that some people are reporting no problems at all. I just wonder if they are spraying their belt.

Anyway, the more I think about this the more PO'ed I get. Just too many people having problems. Who really tested this thing? If I were any of the Pros I would hate to have my name on the box.

2 - Raptor 50's V2

PM  EMAIL  GALLERY  Attn:RR  Quote
03-10-2008 03:31 AM  10 years agoPost 13
3Dx

rrElite Veteran

Monterrey NL

My Posts: All  Forum  Topic

Why has Raptor been flying belt heli's for years and no one ever claimed this issue ????
Good point!

PM  EMAIL  GALLERY  Attn:RR  Quote
03-10-2008 03:32 AM  10 years agoPost 14
dieselracer

rrApprentice

vista CA

My Posts: All  Forum  Topic

sounds like they wernt gorunded properly. If they were grounded properly. there would be no build up on the tail blades.

Blade CPP from hell. powered by NEU, T600 12S

PM  EMAIL  Attn:RR  Quote
03-10-2008 03:32 AM  10 years agoPost 15
dmkc929

rrApprentice

Illinois

My Posts: All  Forum  Topic

hrosee You mean 6 planks....!!!
I seen one demolished in your gallery, lol....
How many people are having problems using the x9303 vs the dx7 or any modules added to make 2.4 ???? I have the x9303...I've seen alot of people posting problems and using the dx7. Is this a Spektrum issue and not a JR 2.4 issue ???

PM  EMAIL  GALLERY  Attn:RR  Quote
03-10-2008 04:02 AM  10 years agoPost 16
hrosee

rrApprentice

Richardson, Texas

My Posts: All  Forum  Topic

That plank that was destroyed was a guy that was flying and hit my Raptor 50 in mid air. He lost. I made it to the ground with only a broken link but landed in one piece.

Two more sets of servo gears and mine will be back together. I just have to decide if I am going to fly it or park it.

I noticed that Jason K. and Alan S. have their names on the box as the designers. Where are they? I have seen them on these forums before but I guess they are hiding now. I don't think they did there testing very well.

I think this will continue as long as we buy Align. Maybe if we stop buying their products until they speak up about this they will fix it. I am convinced that knowone really knows what the problem is. All this static testing and we still have problems........

2 - Raptor 50's V2

PM  EMAIL  GALLERY  Attn:RR  Quote
03-10-2008 04:38 AM  10 years agoPost 17
Helisonmymind

rrApprentice

Toronto, Canada

My Posts: All  Forum  Topic

maybe the raptor's are more tried and proven? They seem a bit lower tech but they *are* strong.

What's the Raptor E550 like as compared with the T-Rex 500?

Helisonmymind: 450 Pro, 500ESP, 600ESP 8S, 600NSP, Quark SRB. ***Thanks RunRyder!!!***

PM  EMAIL  GALLERY  Attn:RR  Quote
03-10-2008 05:34 AM  10 years agoPost 18
hrosee

rrApprentice

Richardson, Texas

My Posts: All  Forum  Topic

You know I wonder if it's really the belt causing all the problem.

There is a lost of voltage being read off the main gear and I can't get rid of it. I saw one guy that put some stay fresh statis remover on his main gear and it stopped it. I did that with no effect.

I ran my 450se up and it also gets a voltage reading off the main gear so I discounted that and dealt with the tail.

As far as the comment about the grounding the tail blades are plastic and electrically insulated from the rest of the heli. Some times they read voltage and sometimes they don't. Depends on the temp in the air. I tested that over the past 3 weeks and it does it at different times depending on the weather.

All I know is until someone comes out with a fix you would have to be crazy to buy one of these. It's pot luck on whether or not you will have4 problems. From what I read it can happen at any time. 3 flights like mine, 20 flight like my friend, or 60 flights like 3dx.

Somebody hurry up and figure this out.

2 - Raptor 50's V2

PM  EMAIL  GALLERY  Attn:RR  Quote
03-10-2008 05:43 AM  10 years agoPost 19
dieselracer

rrApprentice

vista CA

My Posts: All  Forum  Topic

If you ground the tail shaft. you wont get build up in your tail blades. i tested mine and got nothing out of my tail blades.

Blade CPP from hell. powered by NEU, T600 12S

PM  EMAIL  Attn:RR  Quote
03-10-2008 05:48 AM  10 years agoPost 20
hrosee

rrApprentice

Richardson, Texas

My Posts: All  Forum  Topic

Dieselracer,

I am ground and so was the other guy. Like I said here in the Dallas area we get the static buildup on some days from the tail blades and other we don't.

I just hope everyone is on the right track with their research. I have all the know fixes except I forgot to spray the belt today after a few weeks of it sitting here. Next time I won't forget to do that and if my problems go away then I will just spray.

Until and if a tork tube comes out we will never know for sure if the belt is the only problem.

2 - Raptor 50's V2

PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 3 pages [ <<    <    ( 1 )     2      3     NEXT    >> ] 3569 views POST REPLY
HomeAircraftHelicopter
e-
Align
T-REX 500 › What now??
 Print TOPIC  Make Suggestion 

 10  Topic Subscribe

Sunday, June 24 - 8:37 am - Copyright © 2000-2018 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online