RunRyder RC
 1  Topic Subscribe
WATCH
 1 page 399 views POST REPLY
HomeAircraftHelicopterEngines Plugs Mufflers Fuel › OS 50 Hyper and YS 90 -ST problem
03-08-2008 03:47 PM  10 years agoPost 1
Tommy8275

rrVeteran

Mount Juliet, TN

My Posts: All  Forum  Topic

hi guy, I got prblem to start my OS 50 hyper. It was ran fine until I invert my raptor for a little while and start to die on and stop . When I pulled the glow plug out It was dead repleace a new one and I tried to start but couln't get to start only smoke came out from the pipe. Can you experience guy tell me why? And I have another problem

with my YS91-ST was over fine .switch Idle up fly less than 3 second engine start to slow or die down. When I stop the the engine pulled out the check valve no pressure air what cuase that?

Tommy K

PM  EMAIL  GALLERY  Attn:RR  Quote
03-08-2008 03:52 PM  10 years agoPost 2
george0079

rrElite Veteran

USA

My Posts: All  Forum  Topic

Sounds like your getting lean runs on both engines. Change out your clunk lines, and change all of your fuel lines. Then tear down those engines and inspect them. You'll probably need to, at least, change the rings....

Hell... I can fix that.
Uh oh..
Nope.
It's ***ked!!!
RE-KIT!!!!!

PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 399 views POST REPLY
HomeAircraftHelicopterEngines Plugs Mufflers Fuel › OS 50 Hyper and YS 90 -ST problem
 Print TOPIC  Make Suggestion 

 1  Topic Subscribe

Saturday, June 23 - 5:22 pm - Copyright © 2000-2018 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online