RunRyder RC
 19  Topic Subscribe
WATCH
 3 pages [ <<    <     1      2     ( 3 )    >    >> ] 3957 views POST REPLY
HomeAircraftHelicopter
e-
Align
T-REX 500 › Who's 500 flys "WITHOUT" any interferance problems??!
03-09-2008 12:54 AM  10 years agoPost 41
p00rboi

rrNovice

Rockville, VA-USA

My Posts: All  Forum  Topic

No problems after 15 flights. Spektrum 6200 rx. No mods.

PM  EMAIL  Attn:RR  Quote
03-09-2008 03:46 AM  10 years agoPost 42
MMike

rrElite Veteran

Holland,Mi-USA

My Posts: All  Forum  Topic

My 500 is doing fine even though I hold it wrong.

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
03-10-2008 01:30 AM  10 years agoPost 43
the hitmaker

rrApprentice

LA

My Posts: All  Forum  Topic

Yup!!! Add me on the list I put 4 flights on mine today and all I can say is YESS!!!!! It's ROCK solid! I had NO inter. problems i loved it.

PM  EMAIL  GALLERY  Attn:RR  Quote
03-10-2008 01:32 AM  10 years agoPost 44
MMike

rrElite Veteran

Holland,Mi-USA

My Posts: All  Forum  Topic

Glad you like it.

We ALL want to know, did you get your yellow canopy ???

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
03-10-2008 03:29 AM  10 years agoPost 45
geoffrey

rrNovice

Delft

My Posts: All  Forum  Topic

8 flights on mine, everything stock, Carbon Frame

NO PROBLEMS HERE

PM  EMAIL  GALLERY  Attn:RR  Quote
03-10-2008 03:38 AM  10 years agoPost 46
3Dx

rrElite Veteran

Monterrey NL

My Posts: All  Forum  Topic

I Flew mine for about 40-60 flight with out problems at all……

But now it is full of interference issues, (failsafe after failsafe) crashed ones and i can’t find the problem now!!!!

I was as happy as you all Guys……

But seems that the interference issue can appear rapidly with out warning.

Be careful Guys….

PM  EMAIL  GALLERY  Attn:RR  Quote
03-10-2008 05:39 AM  10 years agoPost 47
Helisonmymind

rrApprentice

Toronto, Canada

My Posts: All  Forum  Topic

I know someone who had a very strange problem similar to what's going on here, but with his Raptor 30. The belt was rubbing on the boom, causing interference and lots of problems. Maybe the same problem exists with the 500?

Helisonmymind: 450 Pro, 500ESP, 600ESP 8S, 600NSP, Quark SRB. ***Thanks RunRyder!!!***

PM  EMAIL  GALLERY  Attn:RR  Quote
03-10-2008 05:41 AM  10 years agoPost 48
Helisonmymind

rrApprentice

Toronto, Canada

My Posts: All  Forum  Topic

I'd be adding "touch wood" to a lot of these posts.

http://www.jchowheli.com/home/?p=71

Helisonmymind: 450 Pro, 500ESP, 600ESP 8S, 600NSP, Quark SRB. ***Thanks RunRyder!!!***

PM  EMAIL  GALLERY  Attn:RR  Quote
03-10-2008 12:22 PM  10 years agoPost 49
MMike

rrElite Veteran

Holland,Mi-USA

My Posts: All  Forum  Topic

I've had lock outs on an EP100 BEFORE I started spraying my belt.

Horizon says "spray the belt".

[quote] know someone who had a very strange problem similar to what's going on here,

This is a common 2.4 issue.

The only thing "strange" to me is that the Spectrum stuff doesn't come with intructions to "spray the belt".

I would be VERY surprised if Jason Chow sprayed his belt and crashed.

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
03-10-2008 01:40 PM  10 years agoPost 50
Dr Lodge

rrElite Veteran

Guildford, Surrey - UK

My Posts: All  Forum  Topic

The belt was rubbing on the boom, causing interference and lots of problems
Just a thought, I wonder if this is causing problems where the belt is slightly on the loose side, causing it to make contact/rub with the boom or itself?

Vibe 90, Vibe 50, Vigor CS x2,
Dyna-x, Knight 503D, Logo 10,
TRex 500, Furion, Gaui EP200

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
03-10-2008 04:30 PM  10 years agoPost 51
trexflyer2003

rrVeteran

northridge ca,91324

My Posts: All  Forum  Topic

Flew mine for about 40-60 flight with out problems at all……

But now it is full of interference issues, (failsafe after failsafe) crashed ones and i can’t find the problem now!!!!

I was as happy as you all Guys……

But seems that the interference issue can appear rapidly with out warning.

Be careful Guys….
-------------------------------------

never have any problem with my t500 but hear so many interference issues.

I feel unsafe to fly mine. I did ground the frame but never spray the belt.
It is dangerous to fly mine now. I will probally ground it untill the torque tube come out.

PM  EMAIL  GALLERY  Attn:RR  Quote
03-10-2008 04:41 PM  10 years agoPost 52
Eco8gator

rrElite Veteran

Palm Beach, FL

My Posts: All  Forum  Topic

After flying the 500 feel the boom. Youll feel that its surprisingly warm...so something is rubbing. No matter how tight you get the belt it still gets warm. Usnig lube gets these temps down but the simple fact is the belt flairs up enough to rub.

Curious could those with glitch problems please post pics of their electrical layouts vs the guys with no glitching.

Maybe we can find a common theme. Also average humidity at the fields for each person.

C

PM  EMAIL  GALLERY  Attn:RR  Quote
03-10-2008 05:10 PM  10 years agoPost 53
MMike

rrElite Veteran

Holland,Mi-USA

My Posts: All  Forum  Topic

Maybe we can find a common theme
The common theme is that 100 percent of the 2.4 type resets
(caused by static electricity) are with those that don't spray their belts before a flying session.

If there is someone that knows otherwise, please share your experience.

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
03-12-2008 08:10 AM  10 years agoPost 54
the hitmaker

rrApprentice

LA

My Posts: All  Forum  Topic

yeah but not everybody that hasnt had proble,s sprayed their belts....

PM  EMAIL  GALLERY  Attn:RR  Quote
03-12-2008 08:57 AM  10 years agoPost 55
Heliguychris

rrKey Veteran

Perth, West Australia

My Posts: All  Forum  Topic

Right on hitmaker, i recon the problem lies elsewhere. Not necessarily bad installs, but combinations of factors to do with how radio waves work?? Is it only a 2.4 thing, or is it common on 35,36,40,72 Mhz as well?

[/quote]yeah but not everybody that hasnt had proble,s sprayed their belts....[quote]

Neva have, neva will Dont recon ya need to.

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
03-12-2008 12:17 PM  10 years agoPost 56
MMike

rrElite Veteran

Holland,Mi-USA

My Posts: All  Forum  Topic

[quote]yeah but not everybody that hasnt had proble,s sprayed their belts....

Hit, I'm not saying that if you don't spray, you'll have issues for sure.

THAT would be a leap in logic.

However, I am saying 100 percent of those that had issues, didn't spray their belt.

So: If you want to risk reset issues, don't spray your belt.

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
03-12-2008 01:22 PM  10 years agoPost 57
charliedoane

rrApprentice

Branford, CT USA

My Posts: All  Forum  Topic

No problems after about 20 + flights now. I spray my belt with silicone spray after every 5-10 flights. Have flow it on a very dry day with low humidity. Was getting static shocks from everything else but nothing on the 500. Flies like a dream.

PM  EMAIL  GALLERY  Attn:RR  Quote
03-12-2008 04:19 PM  10 years agoPost 58
3Dx

rrElite Veteran

Monterrey NL

My Posts: All  Forum  Topic

I think spraying the belt is a myth, at my first 40-50+ flights I never spray the belt and hade no problems at all, then the “static interference lockout, failsafe problem” appear with out warning….

Now am spraying the belt and the problem seem to be worst…..

I don’t know what to do now……

PM  EMAIL  GALLERY  Attn:RR  Quote
03-12-2008 04:28 PM  10 years agoPost 59
kingair

rrKey Veteran

Utah - USA

My Posts: All  Forum  Topic

Now am spraying the belt and the problem seem to be worst…
You'd be the first then. Sounds like you have something else going on.

There is a very fine line between "hobby" and "mental illness."

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
03-12-2008 04:31 PM  10 years agoPost 60
MMike

rrElite Veteran

Holland,Mi-USA

My Posts: All  Forum  Topic

After reading 3D's posts, I agree with King.

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
WATCH
 3 pages [ <<    <     1      2     ( 3 )    >    >> ] 3957 views POST REPLY
HomeAircraftHelicopter
e-
Align
T-REX 500 › Who's 500 flys "WITHOUT" any interferance problems??!
 Print TOPIC  Make Suggestion 

 19  Topic Subscribe

Tuesday, June 19 - 11:19 pm - Copyright © 2000-2018 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online