RunRyder RC
 0  Topic Subscribe
WATCH
 1 page 424 views TOPIC CLOSED
HomeAircraftHelicopter
e-
Mikado
Other › whats wrong with my logo power system
03-05-2008 05:29 PM  10 years agoPost 1
soberflierross

rrApprentice

Cottage Grove, MN USA

My Posts: All  Forum  Topic

heres my setup
logo 10 with novaman frame and 500mm mah blades

neu 1910/1y 20 tooth pinion
jazz 55-10-32
6s 25c 5000mah tp packs
the lightest paddles I can find

+12 -12 pitch

It flips alright but it rolls slow, it seemed like it needed more headspeed so I tried a 21 tooth pinion and my motor would bog in flip.

Im running the throttle curve
regular 0-65-100
idle up 98-98-98

it doesnt seem like theres a huge jump in headspeed from regular to idle up

I tried resetting step 1 and 4 in the esc more than once is there something else in the jazz esc I should be programming the guy I bought the esc from was using it for ap work.

thanks Ross

PM  EMAIL  GALLERY  Attn:RR
03-05-2008 05:55 PM  10 years agoPost 2
Jag72

rrProfessor

South of Boston

My Posts: All  Forum  Topic

Jazz esc...
the Jazz esc set in heli mode deafaults to a Governed mode..meaning that the throttle curves should be set "FLAT" ...and usually anything over like 85% is usually maxed out

so if you are trying to run throttle curves it's not going to work well..at least not if you are in fact in heli mode..

I would just run the gov mode as this is the BEST feature of the jazz...

as for the slow flip rate...what is your swash travel set at? and also...how far out on the servo arms are your ball links?...to get MAX travel on the lgo 10 you need to be 20mm out...

My logo 10's have always had BALLISTIC cyclic speed and authority..

of course I also run the 440mm align flybar as well...that really helps out also...

BTW...the MAH blades kind of suck...those are very slow on the cyclics to begin with...get something like the Mikado 500's and you'll get better speed right there..

PM  EMAIL  GALLERY  Attn:RR
03-05-2008 06:34 PM  10 years agoPost 3
soberflierross

rrApprentice

Cottage Grove, MN USA

My Posts: All  Forum  Topic

I moved my curves down to a straight 85 and it came alive

0-65-85 in normal
85-85-85 in idle up

thanks guys Ross

PM  EMAIL  GALLERY  Attn:RR
WATCH
 1 page 424 views TOPIC CLOSED
HomeAircraftHelicopter
e-
Mikado
Other › whats wrong with my logo power system
 Print TOPIC  Make Suggestion 

 0  Topic Subscribe

Sunday, June 24 - 4:45 am - Copyright © 2000-2018 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online