RunRyder RC
 2  Topic Subscribe
WATCH
 2 pages [ <<    <    ( 1 )     2     NEXT    >> ] 1020 views POST REPLY
HomeAircraftHelicopterAlignOther › 600 nitro pro lockout. why?
03-05-2008 01:59 AM  10 years agoPost 1
KsSportflyer

rrApprentice

Louisburg, Kansas

My Posts: All  Forum  Topic

I was flying my second tank tonight. When I was in a tail in hover about 20 feet up. The heli I guess locked up and rolled right. I had know control with the transmitter, and watched it pound the ground hard. I have the 2 in 1 regulator, a dx6i tx with a spectrum ar6200 receiver. The battery level still had one green light on display. This is my first nitro and I loved it. I have been flying for 3 years now. I have a t-rex 450, and a blade 400. The 600 flew so sweet. I am just frustrated because the crash wasnt because of my flying but something I couldnt control. Anyone have any suggegstions or help so I know what to do when I rebuild. Thanks.

PM  EMAIL  GALLERY  Attn:RR  Quote
03-05-2008 02:03 AM  10 years agoPost 2
george0079

rrElite Veteran

USA

My Posts: All  Forum  Topic

There are alot of things that could have caused it... Something as simple as a loose connection.... Or as bad as a faulty receiver....

Hell... I can fix that.
Uh oh..
Nope.
It's ***ked!!!
RE-KIT!!!!!

PM  EMAIL  GALLERY  Attn:RR  Quote
03-05-2008 02:09 AM  10 years agoPost 3
KsSportflyer

rrApprentice

Louisburg, Kansas

My Posts: All  Forum  Topic

Very true. When I got to the heli after the crash I turned the switch on the heli off then on and had control of the servos again. I talked with a guy I know who has been flying for 22years. His first question was about my battery. Then when I told him I had a green light left he asked about the 2 in 1. I really dont know just looking for advice. Thanks.

PM  EMAIL  GALLERY  Attn:RR  Quote
03-05-2008 02:12 AM  10 years agoPost 4
george0079

rrElite Veteran

USA

My Posts: All  Forum  Topic

The first thing that I would do is put that battery on a load tester before you charge it. And then, get another battery and check various voltages against the lights on the 2in1.

That's a place to start, anyhow.

Hell... I can fix that.
Uh oh..
Nope.
It's ***ked!!!
RE-KIT!!!!!

PM  EMAIL  GALLERY  Attn:RR  Quote
03-05-2008 02:18 AM  10 years agoPost 5
brcg123

rrKey Veteran

Wagoner OK USA

My Posts: All  Forum  Topic

are you using the old 2in1 or the new 2in1? old one does'nt have a case around the switch, just shrink wrapped.








Trex700N, Trex600N, Raptor70, RaptorTitan, GMPCrickett, Visa

PM  EMAIL  GALLERY  Attn:RR  Quote
03-05-2008 02:24 AM  10 years agoPost 6
KsSportflyer

rrApprentice

Louisburg, Kansas

My Posts: All  Forum  Topic

Its the new one then. It really destroyed the heli. I bought it off ebay about a month ago. The heli come loaded, all I had to do was put a receiver in it. I had a really experienced pilot set it up for me since I havent had a heli of this caliber. Hopefully I will figure out the problem that way when I get it rebuilt It wont happen again.

PM  EMAIL  GALLERY  Attn:RR  Quote
03-05-2008 02:30 AM  10 years agoPost 7
brcg123

rrKey Veteran

Wagoner OK USA

My Posts: All  Forum  Topic

i cant help whats happened so far, but I have just posted a thread on the new quick-connect receivers spectrum is sending out, when you crashed the receivers will be still blinking, indicating your receiver went below 4v or lost connection, main thing would have been for you is it would have reconnected before you noticed it went off, if that's what happened to you.








Trex700N, Trex600N, Raptor70, RaptorTitan, GMPCrickett, Visa

PM  EMAIL  GALLERY  Attn:RR  Quote
03-05-2008 02:41 AM  10 years agoPost 8
KsSportflyer

rrApprentice

Louisburg, Kansas

My Posts: All  Forum  Topic

Something like that had to of happened. I will be really gun shy from now on. I mean thats something I never thought would happen. I thought the first time I crashed it would be from getting a little wild with it. I think the battery is a 7.4v 1900mah lipo. I dont think the battery was to low because when we set it up a month ago I hovered with 2 red lights left on. But not for very long. I think there is 3 green lights and 2 red. There was still one green and 2 red left on. Thanks

PM  EMAIL  GALLERY  Attn:RR  Quote
03-05-2008 03:36 AM  10 years agoPost 9
brcg123

rrKey Veteran

Wagoner OK USA

My Posts: All  Forum  Topic

i agree, i think the 2in1 has had a slow start for reliability. lots have had the same thing happen, for "no reason".








Trex700N, Trex600N, Raptor70, RaptorTitan, GMPCrickett, Visa

PM  EMAIL  GALLERY  Attn:RR  Quote
03-05-2008 03:46 AM  10 years agoPost 10
KsSportflyer

rrApprentice

Louisburg, Kansas

My Posts: All  Forum  Topic

I just pulled the battery out and checked the volts. It was 7.8v so I dont think it was the battery. I might try a new receiver. I wish there was a way to know exactly what it is. That way you know what to do about it. If it happens again after I rebuild Im done. At least thats what my wife said.

PM  EMAIL  GALLERY  Attn:RR  Quote
03-05-2008 03:49 AM  10 years agoPost 11
KsSportflyer

rrApprentice

Louisburg, Kansas

My Posts: All  Forum  Topic

Do you think I should try something else instead of the 2in1? If so what would be the best to try?

PM  EMAIL  GALLERY  Attn:RR  Quote
03-05-2008 03:58 AM  10 years agoPost 12
brcg123

rrKey Veteran

Wagoner OK USA

My Posts: All  Forum  Topic

if not another 2in1 , at least i would consider upgrading to the new receivers with the quick connect system in them and it wont happen again. it will re boot before you know it went off.








Trex700N, Trex600N, Raptor70, RaptorTitan, GMPCrickett, Visa

PM  EMAIL  GALLERY  Attn:RR  Quote
03-05-2008 04:00 AM  10 years agoPost 13
KsSportflyer

rrApprentice

Louisburg, Kansas

My Posts: All  Forum  Topic

Okay, I have a spectrum dx6i tx. What receiver would be best with it. The ar 6200 that comes with it is what I have on the heli now. Thanks.

PM  EMAIL  GALLERY  Attn:RR  Quote
03-05-2008 04:08 AM  10 years agoPost 14
KsSportflyer

rrApprentice

Louisburg, Kansas

My Posts: All  Forum  Topic

wonder if maybe my lipo failed? I need to get a balancer for it. But the volts stil said 7.8 so I dont know.

PM  EMAIL  GALLERY  Attn:RR  Quote
03-05-2008 04:10 AM  10 years agoPost 15
brcg123

rrKey Veteran

Wagoner OK USA

My Posts: All  Forum  Topic

the AR7000 is a 7 ch receiver, the AR9ooo is a 9 ch reciver, both are great, but you would be far ahead to order it from Horrizon to insure you get the new quick connect system. it is just coming out. Spectrum is having a "Great 2.4 givaway" where you can get a buy one get one sale on moduales and radios, you might try asking to see if you could qualify for one. you can go to Spectrum.com and download the forms to mail in. i hope this works for you.








Trex700N, Trex600N, Raptor70, RaptorTitan, GMPCrickett, Visa

PM  EMAIL  GALLERY  Attn:RR  Quote
03-05-2008 04:12 AM  10 years agoPost 16
brcg123

rrKey Veteran

Wagoner OK USA

My Posts: All  Forum  Topic

wait a minute, you know you are using a radio thats not for trex 600s, right?








Trex700N, Trex600N, Raptor70, RaptorTitan, GMPCrickett, Visa

PM  EMAIL  GALLERY  Attn:RR  Quote
03-05-2008 04:14 AM  10 years agoPost 17
KsSportflyer

rrApprentice

Louisburg, Kansas

My Posts: All  Forum  Topic

I didnt know about that. I recently met a fellow that has been flying since 1986. He said that it would be fine. I have been debating on getting a dx7.

PM  EMAIL  GALLERY  Attn:RR  Quote
03-05-2008 04:21 AM  10 years agoPost 18
brcg123

rrKey Veteran

Wagoner OK USA

My Posts: All  Forum  Topic

the dx6 is not a full something radio, its for park flyers and maybe the trex 450, but not for full size helis, thats probubly why you crashed! you lost contact with the receiver altogether. you need to buy a new radio, then you get a free receiver though. get a dx7 and sell your dx6. theres nothing wrong with it just not for 50 size helis.








Trex700N, Trex600N, Raptor70, RaptorTitan, GMPCrickett, Visa

PM  EMAIL  GALLERY  Attn:RR  Quote
03-05-2008 04:28 AM  10 years agoPost 19
Ken Filloon

rrVeteran

Highland, Michigan

My Posts: All  Forum  Topic

Are you using the stock JST battery connector's?

PM  EMAIL  GALLERY  Attn:RR  Quote
03-05-2008 04:56 AM  10 years agoPost 20
Zaneman007

rrElite Veteran

Texas - USA

My Posts: All  Forum  Topic

Did you check your servos?

I had a servo go bad and it did the same thing. Rolled over and hit the ground.

Old Guys Rule!

PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 2 pages [ <<    <    ( 1 )     2     NEXT    >> ] 1020 views POST REPLY
HomeAircraftHelicopterAlignOther › 600 nitro pro lockout. why?
 Print TOPIC  Make Suggestion 

 2  Topic Subscribe

Sunday, June 24 - 10:13 am - Copyright © 2000-2018 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online