RunRyder RC
 2  Topic Subscribe
WATCH
 1 page 428 views POST REPLY
HomeAircraftHelicopter
e-
Blade
Blade 400 › 3D 2 ESCs in a row have smoked
03-04-2008 05:09 AM  10 years agoPost 1
duff

rrApprentice

Calgary, Alberta, Canada

My Posts: All  Forum  Topic

I have replaced the stock ESC with the 25amp one from eflite twice now. For some reason with no throttle the ESC will go up in smoke at random. Bad motor? Other then this happing out of nowhere the bird works great. Any Ideas?

Thanks

Edit: I also upgraded my servos to HS65mg's

PM  EMAIL  GALLERY  Attn:RR  Quote
03-04-2008 04:16 PM  10 years agoPost 2
davidg51537

rrApprentice

Back in Omaha, NE

My Posts: All  Forum  Topic

Have you called HH?

That is really strange. Check your battery connector. Maybe there is a short there. You need to identify what is smoking. Is it the on board BEC or is it really the ESC portion that is burning up.

David

PM  EMAIL  GALLERY  Attn:RR  Quote
03-04-2008 06:11 PM  10 years agoPost 3
Tioli

rrVeteran

Kona, Hawaii

My Posts: All  Forum  Topic

I don't think it's anything you're doing. HH has said there is some history of this happening. They're great about replacing them, though...

We've had one go up in smoke(out of 5-6 B400's).

PM  EMAIL  GALLERY  Attn:RR  Quote
03-04-2008 06:53 PM  10 years agoPost 4
duff

rrApprentice

Calgary, Alberta, Canada

My Posts: All  Forum  Topic

Looks like power mosfets that are toasting.


Tioli how long does it take for Eflite to send a new ESC?

PM  EMAIL  GALLERY  Attn:RR  Quote
03-04-2008 07:01 PM  10 years agoPost 5
davidg51537

rrApprentice

Back in Omaha, NE

My Posts: All  Forum  Topic

I would say that is more than infant mortality on the Speed Control.

Look at the battery connector and make sure there are no shorts. Also check the motor for a dead short as well.

David

PM  EMAIL  GALLERY  Attn:RR  Quote
03-04-2008 07:07 PM  10 years agoPost 6
duff

rrApprentice

Calgary, Alberta, Canada

My Posts: All  Forum  Topic

David how would I check the motor?

PM  EMAIL  GALLERY  Attn:RR  Quote
03-04-2008 07:28 PM  10 years agoPost 7
duff

rrApprentice

Calgary, Alberta, Canada

My Posts: All  Forum  Topic

another thing... its the pro ESC

PM  EMAIL  GALLERY  Attn:RR  Quote
03-04-2008 08:47 PM  10 years agoPost 8
Torquestar

rrNovice

California

My Posts: All  Forum  Topic

I may be way off, but I remember reading something about someone doing something with their heli, but the blades were folded back in their holder at the time. When it was powered on, after awhile, the strain on the servos (to fight to stay in their neutral position) was too much for the ESC/BEC and it would fry.

I don't remember the circumstances... and I can't remember if the swash on the B400 is tilted out of level when the blades are folded back into the holder... but by any chance do you have the blade folded back when this is occuring?

PM  EMAIL  Attn:RR  Quote
03-04-2008 09:55 PM  10 years agoPost 9
duff

rrApprentice

Calgary, Alberta, Canada

My Posts: All  Forum  Topic

thanks to all who have replied. I just purchased a new motor and ESC. One thing I have noticed on this blade 400... one of the screws that hold the motor in is stripped... I have never touched this motor. Anyone experience this?

PM  EMAIL  GALLERY  Attn:RR  Quote
03-04-2008 11:14 PM  10 years agoPost 10
duff

rrApprentice

Calgary, Alberta, Canada

My Posts: All  Forum  Topic

Just to update. I have installed a stock ESC with a new motor and things so far are looking well. I found out a LHS sold me a plane ESC as an "Upgrade" from stock. This may have been a problem. I was told it was designed for heli.

PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 428 views POST REPLY
HomeAircraftHelicopter
e-
Blade
Blade 400 › 3D 2 ESCs in a row have smoked
 Print TOPIC  Make Suggestion 

 2  Topic Subscribe

Monday, June 25 - 3:35 am - Copyright © 2000-2018 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online