RunRyder RC
WATCH
 1 page 448 views POST REPLY
Home✈️Aircraft🚁Helicoptere-BladeBlade 400 › 3D Weird swash problem?
02-08-2008 02:23 PM  11 years ago
Topic Vote0Post 1
macsgrafs

rrApprentice

Barnstaple, Devon, UK

MyPosts All Forum Topic
3D Weird swash problem?
I had a smash the other day, replaced a a stripped servo on the pitch with a Hitec HS 65MG. Now please note I have NOT touched the radio setup (DX6i) as there was no need. So I plug in the new servo, turn TX on & have motor disconected, put throttle at mid way & try the aeileron & pitch....my god what's happening...instead of the swash tilting backwards & forwards for the pitch, it seems to be aletring the collective!!!! So I move the throttle & that seems to alter the swash backwards & forwards..it's like the left stick has become right & the right stick has become left...HELP

Regards
Ross
Seems to me that ALL heli's beat the air into submission
SHARE  PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
02-08-2008 02:54 PM  11 years ago
macsgrafs

rrApprentice

Barnstaple, Devon, UK

MyPosts All Forum Topic
Problem solved...had to reverse the servo, how stupid of me

Ross
Seems to me that ALL heli's beat the air into submission
SHARE  PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
WATCH
 1 page 448 views POST REPLY
Home✈️Aircraft🚁Helicoptere-BladeBlade 400 › 3D Weird swash problem?
 Print TOPIC  Make Suggestion 

 1  Topic Subscribe

Saturday, July 20 - 9:47 pm - Copyright © 2000-2019 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online