RunRyder RC
WATCH
 1 page 1006 views POST REPLY
HomeAircraftHelicopter
e-
Blade
Blade 400 › 3D esc problems
02-05-2008 12:24 AM  10 years agoPost 1
whirlydude

rrApprentice

USA

My Posts: All  Forum  Topic

Anyone having problems with their esc's cutting off prematurely? Sometimes I get 2 minutes, sometimes 4 minutes it varies. Sometimes it doesn't cutoff at all. (within the 5 minute range) I am using a couple different lipos, and I can't believe I dropping to 9 volts under load that fast. Also when arming the esc sometimes it arms right away within 15 seconds, and sometimes it does not arm at all. I unplug and power up again, and at times it takes longer than the 15 seconds. The esc does not seem to get hot just acts very weird. Inconsistent is a better word, and definitely not to be trusted. I am using the dean connectors from lipo to esc, so I don't believe it's a poor connection. I contacted Horizon, and they want to check it out before replacing. Happy Flyin!

PM  EMAIL  Attn:RR  Quote
02-05-2008 12:57 AM  10 years agoPost 2
Torquestar

rrNovice

California

My Posts: All  Forum  Topic

I've read issues like yours occasionaly, and often times people seem to think it's the ESC. However, it could be the battery charger (or even the battery itself) not working properly, leaving you with an undercharged battery.

I don't know if a fully discharged batter that hits the low voltage cutoff stays at 9V with no load, but have you tried checking the voltage on the battery when this happens? If it's 9V, that's a clue.

Even if it's not, though, it's hard to say the battery is fine. Maybe try timing the charges? See if they seem to last the same.

Also, if you have access to a friend with one of those fancier chargers that tells you how much mAh is being put back into the battery, that might get you some answers as well.

PM  EMAIL  Attn:RR  Quote
02-05-2008 01:19 AM  10 years agoPost 3
whirlydude

rrApprentice

USA

My Posts: All  Forum  Topic

Hey Torquestar,
Thanks for the reply. I thought maybe the charger, but I am using 2 different kinds. I have a TP charger, which is pretty reliable. The other one I was using is the stock Eflite one. I just finished a TP lipo pack, and everything went well. This time anyway. I am going to try the stock Eflite pack next, and see what happens. I have it charging now, so it will be interesting to see if it's the Eflite charger. When this happens with the esc I should have been paying better attention to which pack I was using. Thanks again!

PM  EMAIL  Attn:RR  Quote
02-05-2008 02:31 AM  10 years agoPost 4
Heliman92

rrApprentice

Pennsylvania

My Posts: All  Forum  Topic

A friend of mines esc was burned out when he bought it.

"You can't blame gravity for everthing"

PM  EMAIL  GALLERY  Attn:RR  Quote
02-05-2008 02:49 AM  10 years agoPost 5
whirlydude

rrApprentice

USA

My Posts: All  Forum  Topic

I hovered the 400 for 5 minutes with the Eflite pack, and no problems. After charging was complete the voltage read 12.61. After the 5 minute hover the voltage read 11.19. If my DC source for charging was down on voltage going to the charger would this cause an under charged lipo? I would think it may just take longer to charge, but the voltage would still be put in the lipo. Any suggestions? I normally check the voltage after flying, and it has never been under 11 volts with the Eflite or the TP packs. So I am back to square 1.

PM  EMAIL  Attn:RR  Quote
WATCH
 1 page 1006 views POST REPLY
HomeAircraftHelicopter
e-
Blade
Blade 400 › 3D esc problems
 Print TOPIC  Make Suggestion 

 3  Topic Subscribe

Friday, December 14 - 5:06 am - Copyright © 2000-2018 RunRyder   EMAILEnable Cookies

The RC discussion world needs to consolidate. RR is now one choice for that. Its software is cutting edge. It hosts on-topic advertising. Help RR increase traffic buy making suggestions, posting in RR's new areas (sites) and by spreading the word.

The RunRyder Difference

• Category system to allow Rep/Vendor postings.
• Classifieds with sold (hidden) category.
• Classifieds with separate view new.
• Answer PMs offsite via email reply.
• Member gallery photos with advanced scripting.
• Gallery photo viewer integrated into postings.
• Highly refined search with advanced back end.
• Hosts its own high end fast response servers.
• Hosts thousands of HD event coverage videos.
• Rewrote entire code base with latest technology.
• No off-topic (annoying) click bait advertising.
Login Here
 New Subscriptions 
 Buddies Online