RunRyder RC
WATCH
 1 page 1087 views Post Reply
Home✈️Aircraft🚁Helicoptere-Hirobo Embla - SRB Quark - Lepton › Lepton Blade Grip Slop?
08-06-2007 02:24 AM  13 years ago
Topic Vote0Post 1
Joe Ubaldo

rrVeteran

Grand Rapids, MI USA

MyPosts All Forum Topic
Lepton Blade Grip Slop?
I've noticed my almost new Lepton makes a strange flutter sound while in flight when the blades pass through zero pitch (as in upright to inverted). The blades make almost no sound when flying around with positive or negative pitch...but make a curious flutter sound around zero pitch. I'm using SAB blades and have found the problem persists with other brands of blades too.

After checking out the model on the bench, I've noticed a little bit of blade grip slop and wonder whether this is normal or not. If I grab the blade grips and move them up and down, I feel a bit of slop (grips rock at the end of the spindle) which translates into about an inch of movement at the blade tips. My model has less then 20 flight on it and has not been crashed.

My Evo 50 and Raptor 50 have no slop in the blade grips and thus no slop at the blade tips. I've checked to make sure I have the thrust bearings in the correct orientation and everything is perfectly assembled.

Is the Lepton supposed to have a bit of blade grip slop or is there a problem with mine? Anyone else have this issue with their Lepton?

Thanks in advance for any insight.

Joe
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
08-06-2007 03:48 PM  13 years ago
demosa

rrVeteran

Tigard, Oregon, U.S.A.

MyPosts All Forum Topic
My Lepton has about 10 flights and also has a tiny bit of play on both grips. But it certainly doens't translate to 1 inch of play at the tips of the blades. It's more like a quarter inch, maybe half at the most.

I'm new to the Lepton and I haven't been used to all the wierd sounds it makes. Everytime I fly it, I'm worried that something will fly off. But it flights great and at the end of every flight everything is rock solid. The only thing that I'm watching carefully now is the belt. I am noticing a tiny bit of black dust around the tail rotor case, mostly on the tail blades ...
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
08-06-2007 04:07 PM  13 years ago
demosa

rrVeteran

Tigard, Oregon, U.S.A.

MyPosts All Forum Topic
One thing that I remembered :
Did you disassemble the head or did you use it out of the box ?

I took mine apart and I did see that the bearings fell off out of one grip but were tight on the other grip. I took all bearings off, cleaned the grips well and re-assembled with loctite. I think this may have something to do with blade grip play.
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
08-19-2007 05:42 PM  13 years ago
Joe Ubaldo

rrVeteran

Grand Rapids, MI USA

MyPosts All Forum Topic
Head has been fully checked out. Everything is perfect...just some slop. Anyone have an idea how to get rid of the slop?...maybe a shim or something?
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
08-25-2007 06:20 AM  13 years ago
duceduc

rrKey Veteran

Saitama-Ken, Japan

MyPosts All Forum Topic
I do noticed the sound when I roll the heli over abruptly. Thought it was normal.

I have another issue which I can not find for weeks now. The heli needs to be retrim after every flight. Can't figure out why.
Duc S
Do It! Do It!™
AMA:REVOMIX
RCK:24005615-01
SHARE  PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
08-25-2007 10:25 AM  13 years ago
Jafa

rrElite Veteran

Sydney, Australia

MyPosts All Forum Topic
My Lepton makes some sort of cool blade noise as it rolls over

There is no play in my grips

Re-trimming for each flight is either the battery position/weight being slightly different or the rod ends are a bit tight on the balls (they need to be really fluid)

Protos | Logo 400 & 500 | Sceadu Evo | Freya Evo | Trex600N | Avant FX
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
08-25-2007 11:17 AM  13 years ago
duceduc

rrKey Veteran

Saitama-Ken, Japan

MyPosts All Forum Topic
jafa:
I have shifted the battery forward to counteract the tail heavy weigh. The ball linkages are smooth as well. Thanks for the reply.
Duc S
Do It! Do It!™
AMA:REVOMIX
RCK:24005615-01
SHARE  PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
08-25-2007 11:41 AM  13 years ago
Jafa

rrElite Veteran

Sydney, Australia

MyPosts All Forum Topic
Could also be the centering of servos I guess
Protos | Logo 400 & 500 | Sceadu Evo | Freya Evo | Trex600N | Avant FX
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
10-24-2007 05:35 AM  12 years ago
duceduc

rrKey Veteran

Saitama-Ken, Japan

MyPosts All Forum Topic
Well, finally got a chance to take out the lepton. Unfortunelty, the pitching motion in FF is still there.

Jafa, when you say the linkage have to move fulidly, do you mean like very smooth. Mine is smooth, just like my other helis.

I have switched servos from the beginning when I noticed this issue. It didn't help either.
Duc S
Do It! Do It!™
AMA:REVOMIX
RCK:24005615-01
SHARE  PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
WATCH
 1 page 1087 views Post Reply
Home✈️Aircraft🚁Helicoptere-Hirobo Embla - SRB Quark - Lepton › Lepton Blade Grip Slop?
Print TOPIC

 2  Topic Subscribe

Tuesday, September 29 - 4:15 pm - Copyright © 2000-2020 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online