RunRyder RC
WATCH
 1 page 1004 views Post Reply
Home✈️Aircraft🚁Helicoptere-Thunder TigerRaptor E325 › MT, anyone having this problem?
08-02-2007 08:33 PM  13 years ago
Topic Vote0Post 1
bob vickers

rrNovice

southern u.k.

MyPosts All Forum Topic
MT, anyone having this problem?
I have the mini titan standard heli flying perfect on the wood blades..I fit the carbon blades and get the tracking problems..so..I fit the entire TT metal upgrades and fit carbon blades...no tracking problems at all...but...the collective is wishy washy...like the model is on a bunje line...no precise control..it goes above or below where you want to hover!...anyone else noticed this?..I have striped the metal stuff off and on and there is no play anywhere!!!!

help.
mini-titan e-325
SHARE  PM  EMAIL  Attn:RR  Quote
08-02-2007 09:01 PM  13 years ago
raptorman57

rrNovice

Vacarisses, Barcelona- Spain

MyPosts All Forum Topic
Red grommets are smaller than aluminium hole in TT upgrades, put some teflon tape or vinyl tape between both and your problem will dissappear, you can also, instead, add another washing with same results. I had the same problem an was solved in this way.
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
08-03-2007 09:57 AM  13 years ago
RotorHead486

rrKey Veteran

England

MyPosts All Forum Topic
Hey,

I have had a small problem with tracking but i've found this is down to the shims i've used to shim the blades in the grips we not the best and they have allowed the blades to go out of track after a short while, i changed out the washers i'd used to a tail blade spacer and then used the radix spacers that come with the blades and shimed each side up and it's flies perfect now with no tracking issue at all.

Cheers!
RH486
One Reason For Crashing'Rogue Servo Bent on World Domination'!!
FLP Flight Team
SHARE  PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
08-03-2007 12:14 PM  13 years ago
murp

rrApprentice

Nova Scotia, Canada

MyPosts All Forum Topic
I am flying the stock head and have not had any tracking problems until after 50 or so flights. Now it tracks great upright but is way out when hovering inverted. Haven't been able to sort it out yet.
SHARE  PM  EMAIL  Attn:RR  Quote
08-03-2007 03:06 PM  13 years ago
bob vickers

rrNovice

southern u.k.

MyPosts All Forum Topic
my problem of the blades tacking correctly is completely cured by fitting the metal upgrades...but the pitch is awfull now..it is just not quick...its slugish...notice it mostly in a wind when you want to be quick with the collective inputs..it just doesnt keep up with the stick movements...fitted high torque servos...still no good.mini-titan e-325
SHARE  PM  EMAIL  Attn:RR  Quote
08-03-2007 03:12 PM  13 years ago
Hazy

rrNovice

Singapore

MyPosts All Forum Topic
I do have tracking problem with carbon blades.But I have not try together with a CNC rotor head yet.
SHARE  PM  EMAIL  Attn:RR  Quote
08-03-2007 04:31 PM  13 years ago
pigs dont fly

rrKey Veteran

City, State - Country

MyPosts All Forum Topic
I have no tracking issues either, I have Align CF 3k blades, TT blade spacers and the red dampers, no mods to the blade grips or anything else. Tracks fine for me, inverted and sunny side up, even after a ton of crazy pitch pumping and tic tocs.Warning...This hobby is very addictive and may damage your wealth
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
08-03-2007 09:08 PM  13 years ago
murp

rrApprentice

Nova Scotia, Canada

MyPosts All Forum Topic
I just rebuilt the stock head on mine and realized there was a lot of slop. I am hoping that simply maintenance will resolve my issue. It has always tracked great upright and inverted until now so I know the stock head can work well. It was just in need of some tightening (at least I hope). Should get a chance to try it out this weekend.
SHARE  PM  EMAIL  Attn:RR  Quote
08-03-2007 11:20 PM  13 years ago
SSchulz

rrApprentice

San Diego, Ca.

MyPosts All Forum Topic
Hey Bob:

I have a similar issue with my MT. The feel in normal mode is as you describe. Feels like its on a bungee line(mostly around center stick when hovering or landing).
Most of the head is metal and all linkages are tight. Servo's are HS 65 mg's. I tried playing with the normal pitch curve (-5 and +8)by reducing the amount both negative and positive thinking it might change that sloppy feel. It didn't help much.
In idle up mode (-11 and +11)it is precise and has a good feel to it. I think it might have something to do with the HS. I am running approx 2600 in normal and 3000 in idle up. I have not experienced this issue with my Trex or other heli's. Let me know what you find.
I refuse to tip toe thru life only to arrive safely at death
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
08-05-2007 11:34 PM  13 years ago
bob vickers

rrNovice

southern u.k.

MyPosts All Forum Topic
At the moment it has the full metal parts from the swash upwards...and I have the strange bunje feel on collective..I am thinking of taking one metal part off at a time ..replacing with the original part and try that till i find the problem.mini-titan e-325
SHARE  PM  EMAIL  Attn:RR  Quote
08-05-2007 11:57 PM  13 years ago
kswind

rrNovice

Hutchinson, Kansas-USA

MyPosts All Forum Topic
E325MT
I have Radix carbon blades and a 1/32 inch aircraft plywood shim in a triangular shape CYd to the bottom of the blades made the tracking good on my machine. I do believe the yo yo action is caused by low headspeed.
SHARE  PM  EMAIL  Attn:RR  Quote
WATCH
 1 page 1004 views Post Reply
Home✈️Aircraft🚁Helicoptere-Thunder TigerRaptor E325 › MT, anyone having this problem?
Print TOPIC

 6  Topic Subscribe

Friday, September 25 - 1:33 am - Copyright © 2000-2020 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online