RunRyder RC
WATCH
 1 page 520 views Post Reply
Home✈️Aircraft🚁HelicopterBeginners Corner › Swash Help?
07-30-2007 11:33 PM  13 years ago
Topic Vote0Post 1
Dagger3000

rrNovice

Columbia

MyPosts All Forum Topic
Swash Help?
I have about sixty flights on my Raptor 50 and I noticed that my swash plate is sticking on the mainshaftin certain places. I cleaned it very well and relubed it with a small amount of triflow. I still notice it sticking though I am not sure if it might be due to ware. I also don't know how to check for any ware in the mainshaft or swashplate. Any help would be great.

Thanks, Dagger3000
SHARE  PM  EMAIL  HOMEPAGE  Attn:RR  Quote
07-30-2007 11:48 PM  13 years ago
garaptor

rrApprentice

Atlanta,Ga,usa

MyPosts All Forum Topic
I would think the sticking is in your linkage somewhere and not on the shaft itself.
SHARE  PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
07-31-2007 12:09 AM  13 years ago
Dagger3000

rrNovice

Columbia

MyPosts All Forum Topic
I checked the linkage and there is no binding at all I still think it might be the swashplate or shaft...I have no clue at this point.Thanks anyway..
SHARE  PM  EMAIL  HOMEPAGE  Attn:RR  Quote
07-31-2007 12:27 AM  13 years ago
Zephan

rrApprentice

Lompoc, CA

MyPosts All Forum Topic
It very well could be a bent main shaft if you have had any crashes. Pull the main shaft out and roll it on a plate of glass or mirror. If it doesn't roll smooth with no gaps under it. It is bent.
Trex600N & Trex450SE... DAMN! Another radio glitch!
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
07-31-2007 12:33 AM  13 years ago
Dagger3000

rrNovice

Columbia

MyPosts All Forum Topic
No crashes either I thought about the bent shaft and checked it also.I wonder if it is even possable to ware out the swash or shaft?
Thanks for your help though.
SHARE  PM  EMAIL  HOMEPAGE  Attn:RR  Quote
07-31-2007 01:58 AM  13 years ago
Lamar Cooley

rrApprentice

Houma,La.,U.S.A.

MyPosts All Forum Topic
Shaft binding on swash
Hey Dagger 3000,
What up?
Disconnect your aileron links and elevator links.
Check to see if the washout is not binding on the guide pins
as the swash is moved up. Any binding on the pins might cause the swash to bind also.
This may be your problem. It's a knee bone connected to the leg bone thing.
I experienced this when installing a metal head with a ring type
pin guide for the washout.
Just my thoughts.
I hope this helps.
I would also like to know what you might find with this check
Regards

Here when wanted.
There when needed.
Everywhere when looked for.
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
08-01-2007 06:31 PM  13 years ago
legoman67

rrElite Veteran

Nanoose Bay B.C, Canada

MyPosts All Forum Topic
is your swash shot? is it the stock raptor v2 plastic swash?
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
08-04-2007 11:25 PM  13 years ago
Dagger3000

rrNovice

Columbia

MyPosts All Forum Topic
Well I pulled the head all apart and disconnected all of the linkages and still binding out the wazzooo. I said the heck with it I will just buy a new shaft and swashplate. Thanks for all of your help and I will put this bird back together and try it again. Thanks guys for all of your suggestions. thanks agin Dagger3000
SHARE  PM  EMAIL  HOMEPAGE  Attn:RR  Quote
08-07-2007 09:15 PM  13 years ago
legoman67

rrElite Veteran

Nanoose Bay B.C, Canada

MyPosts All Forum Topic
get the full metal swash, not the stock plastic one.
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 520 views Post Reply
Home✈️Aircraft🚁HelicopterBeginners Corner › Swash Help?
Print TOPIC

 3  Topic Subscribe

Thursday, September 24 - 3:34 pm - Copyright © 2000-2020 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online