RunRyder RC
WATCH
 2 pages [ <<    <     1     ( 2 )    >    >> ] 1592 views Post Reply
HomeRC & Power✈️Aircraft🚁HelicopterEngines Plugs Mufflers Fuel › OS50 Hyper...really hyper
05-27-2007 05:26 AM  13 years ago
Helijockey

rrKey Veteran

150 miles from somewhere

MyPosts All Forum Topic
DWS6 it's at factory setting. Rymps I already checked that but will do again.
SHARE  PM  EMAIL  Attn:RR  Quote
05-27-2007 08:38 AM  13 years ago
baddynergy

rrElite Veteran

sierra madre, ca- usa

MyPosts All Forum Topic
Also check your throttle curves. You may have your low point to high and its makin the clutch grabby.**Unattended children will be givin a shot of espresso and a puppy**
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
05-27-2007 03:05 PM  13 years ago
Helijockey

rrKey Veteran

150 miles from somewhere

MyPosts All Forum Topic
Hi baddraptor, I notice that michael at raptortechnique shows the normal throttle curve low point at 20, whereas the manual has them at 0. What do u suggest?
SHARE  PM  EMAIL  Attn:RR  Quote
05-28-2007 02:51 PM  13 years ago
Helijockey

rrKey Veteran

150 miles from somewhere

MyPosts All Forum Topic
Redid the thottle and pitch setup, got the blades to stop spinning at idle. Still the headspeed is very high and the engine became very warm with just about a minute of hovering The only thing I haven't replaced is the fuel tank. Although it seems ok still I'll change it in case there is a problem with it.
SHARE  PM  EMAIL  Attn:RR  Quote
WATCH
 2 pages [ <<    <     1     ( 2 )    >    >> ] 1592 views Post Reply
HomeRC & Power✈️Aircraft🚁HelicopterEngines Plugs Mufflers Fuel › OS50 Hyper...really hyper
Print TOPIC

 5  Topic Subscribe

Wednesday, January 20 - 12:24 am - Copyright © 2000-2021 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online