RunRyder RC
WATCH
 1 page 1196 views POST REPLY
Home✈️Aircraft🚁Helicoptere-JR-HeliOther › Head and spindle problem.
01-28-2007 09:04 PM  12 years ago
Topic Vote0Post 1
blimpguy

rrApprentice

Pensacola Beach

MyPosts All Forum Topic
Head and spindle problem.
I replaced the spindle in the head of my voyager and replaced all the
bearings properly. I printed the diagram to make sure i was doing it
correctly.
I got it all back together and the spindle will not tighten flush to the head. I've installed new dampners and i still have slop. I also
tried turning the dampners around to try that, still the spindle will
not tighten the blade grips to the hub. Is there a trick to this ? I even did the whole routine all aver again to make sure I had it right.

Tks

Jeff
SHARE  PM  EMAIL  HOMEPAGE  Attn:RR  Quote
01-29-2007 12:06 AM  12 years ago
Ralphw

rrKey Veteran

Conroe, TX

MyPosts All Forum Topic
It's been awhile since I've looked at the stock VE head so take this with a grain of salt.

I seem to remember that there is a sleeve with a collar that fits over the spindle between the grips and the head block and in at least one (maybe more) of the VE manuals diagrams it is depicted backwards. Try pulling the grips off and reversing the sleeve, I know they were longer on one side of the collar than on the other. Worth a try.
Ralph W.
"Life's Short, Fly Fast"
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 1196 views POST REPLY
Home✈️Aircraft🚁Helicoptere-JR-HeliOther › Head and spindle problem.
 Print TOPIC  Make Suggestion 

 1  Topic Subscribe

Friday, November 22 - 9:17 pm - Copyright © 2000-2019 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online