RunRyder RC
WATCH
 2 pages [ <<    <     1     ( 2 )    >    >> ] 943 views POST REPLY
Home✈️Aircraft🚁Helicoptere-AlignOther › My ESC/Motor wont work
01-27-2007 01:06 AM  12 years ago
jphilli

rrKey Veteran

Atlanta, Ga.

MyPosts All Forum Topic
It's gotta be the ESC. I took the shrink wrap off and all connections are soldered perfectly. The connections from the ESC have no voltage at all.
SHARE  PM  EMAIL  Attn:RR  Quote
01-27-2007 01:23 AM  12 years ago
eyeflyhelis

rrElite Veteran

charlotte nc

MyPosts All Forum Topic
did you try a new batt?
did you try to reset your ESC settings?
only you have the power to make no difference!
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
01-27-2007 01:26 AM  12 years ago
slider46

rrProfessor

Ocala Florida

MyPosts All Forum Topic
You don't have a switch for idleup or t hold on do you? Also your throttle travel should be 0-100 not 100-150....Tom..... No "D" flying....
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
01-27-2007 01:28 AM  12 years ago
VKGT

rrElite Veteran

Sanford, NC

MyPosts All Forum Topic
Like mentioned, check your throttle travel and trim to make sure that you are able to get ZERO throttle when the stick is all the way down. If the ESC is working properly it will beep and arm.
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
01-27-2007 01:42 AM  12 years ago
electriciancarl

rrVeteran

Xxxxxxx

MyPosts All Forum Topic
The Align esc will beep upon power up under any radio settings / condition. If you have voltage to the ESC and no beeps it's probably bad. Not the first one I've heard of.Treat me good, I'll treat you better. Treat me bad, I'll treat you worse.
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
01-27-2007 01:56 AM  12 years ago
leslie

rrKey Veteran

Hollis, NH - USA

MyPosts All Forum Topic
Hi all,

You might try lowering your thottle trim a couple % below 0. I seem to recall having to do this to get my ESC to arm.

Just a thought, before trashing it.

Cheers,
Leslie
Protecting those who protect us
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
01-28-2007 09:55 PM  12 years ago
jphilli

rrKey Veteran

Atlanta, Ga.

MyPosts All Forum Topic
it ended up being a bad ESC. I went out today and got a phoenix 35. Thanks for all the help!
SHARE  PM  EMAIL  Attn:RR  Quote
01-28-2007 10:35 PM  12 years ago
murp

rrApprentice

Nova Scotia, Canada

MyPosts All Forum Topic
Good purchase - did you also get the USB programmer - if so, I would recommend you update to the latest firmware, more features and the governor mode works great!
SHARE  PM  EMAIL  Attn:RR  Quote
01-28-2007 10:59 PM  12 years ago
jphilli

rrKey Veteran

Atlanta, Ga.

MyPosts All Forum Topic
I was just reading some earlier posts where you had described how to properly operate the governor. I will have to go back and get that.
SHARE  PM  EMAIL  Attn:RR  Quote
01-28-2007 11:19 PM  12 years ago
murp

rrApprentice

Nova Scotia, Canada

MyPosts All Forum Topic
If you need any help just let me know - I run the CC ESC in gov mode with the 430L. The CC website duscusses how to set it up in good detail too. Enjoy your new ESC!
SHARE  PM  EMAIL  Attn:RR  Quote
WATCH
 2 pages [ <<    <     1     ( 2 )    >    >> ] 943 views POST REPLY
Home✈️Aircraft🚁Helicoptere-AlignOther › My ESC/Motor wont work
 Print TOPIC  Make Suggestion 

 2  Topic Subscribe

Thursday, November 21 - 11:52 am - Copyright © 2000-2019 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online