RunRyder RC
WATCH
 1 page 569 views POST REPLY
Home✈️Aircraft🚁Helicoptere-BladeOther › Hitec Eclipse 7 with BCPP
01-26-2007 07:38 PM  12 years ago
Topic Vote0Post 1
grock

rrApprentice

Israel

MyPosts All Forum Topic
Hitec Eclipse 7 with BCPP
Hey,
I may buy tomorrow a raptor 30 v1 and hitec eclipse 7 channels.
I wanted to know if I can use this tx with my bcpp.

Does anybody here have this controller? how is it?

Thanks,
Gil.
SHARE  PM  EMAIL  Attn:RR  Quote
01-26-2007 09:26 PM  12 years ago
johndog35

rrApprentice

Kansas City, Kansas

MyPosts All Forum Topic
I have a Hitec Optic 6 for mine. Works great for me.Landings are nothing more than controled crashes
SHARE  PM  EMAIL  Attn:RR  Quote
01-26-2007 09:36 PM  12 years ago
bbeverlie

rrKey Veteran

Hudson,New Hampshire.USA

MyPosts All Forum Topic
I know you can with a Blade CP with stock 4n1AMA#846952
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
01-26-2007 09:49 PM  12 years ago
johndog35

rrApprentice

Kansas City, Kansas

MyPosts All Forum Topic
I use mine with my Blade CX, Blade CP Pro and Brushless motor and my TRex SA. There is some fine tuning but the end result is worth it.Landings are nothing more than controled crashes
SHARE  PM  EMAIL  Attn:RR  Quote
03-28-2007 04:40 AM  12 years ago
Knight Hawke

rrNovice

Advance, Mo...U.S.A.

MyPosts All Forum Topic
Optic 6 set up CX
johndog35

I just got me a Optic 6 for my CX.. What are your setting for your CX. I'm checking out diff. sites looking for settings for my CX.
So far found 2 diff. sets of settings.. Can you help?

Joe
SHARE  PM  EMAIL  Attn:RR  Quote
04-18-2007 06:52 PM  12 years ago
rcs8

rrNovice

Chagrin Falls, OH USA

MyPosts All Forum Topic
Solid Red on LED
Just got the Hitec Eclipse 7 with the spectra module.

With the stock 4-in-1 with the Channel 17 rx crystal, I can get all the servos to work appropriately but the LED stays red and the motors won't turn. Throttle servo is reversed appropriately (doesn't work in normal, either). Trim at zero. Stick at zero. PPM mode.

If the tx weren't communicating with the rx, then the servos would't respond. (I think)

Everything works great with my Futaba 6EXHP so I know it's not the rx.

Any help would be appreciated.
SHARE  PM  EMAIL  Attn:RR  Quote
04-19-2007 02:33 AM  12 years ago
Stack

rrVeteran

Bethlehem, PA

MyPosts All Forum Topic
You need to adjust your throttle end points. If I remember correctly - adjust top and bottom ends out.. adjust top end so that full throttle gives you red light and adjust bottom end so that the 3 in 1 will arm without having to add down trim to the throttle channel.

Worked great with my BCPs.

Let me know if you get stuck. I'll dig the radio back out.
SHARE  PM  EMAIL  Attn:RR  Quote
04-19-2007 02:48 AM  12 years ago
rcs8

rrNovice

Chagrin Falls, OH USA

MyPosts All Forum Topic
Perfect!
Thanks for your help. Up and flying!!
SHARE  PM  EMAIL  Attn:RR  Quote
04-19-2007 02:52 AM  12 years ago
Stack

rrVeteran

Bethlehem, PA

MyPosts All Forum Topic
No prob! just make sure that red light doesn't come on too early.. if it does, back the end point down.
SHARE  PM  EMAIL  Attn:RR  Quote
WATCH
 1 page 569 views POST REPLY
Home✈️Aircraft🚁Helicoptere-BladeOther › Hitec Eclipse 7 with BCPP
 Print TOPIC  Make Suggestion 

 4  Topic Subscribe

Friday, November 22 - 3:12 pm - Copyright © 2000-2019 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online