RunRyder RC
WATCH
 1 page 399 views Post Reply
Home✈️Aircraft🚁Helicoptere-BladeOther › Motor cuts out?
09-05-2006 09:47 PM  14 years ago
Topic Vote0Post 1
rky5

rrVeteran

Oak Hills california

MyPosts All Forum Topic
Motor cuts out?
Motor seems to cut out for a second or two then its ok again ........got a new motor didnt help...seems like its a glitch but it does it to often ....checked both antenna's the one on the TX is new the reciever rx antenna wire looks good its like its always been .........can the 4-1 be cutting out?
SHARE  PM  EMAIL  Attn:RR  Quote
09-06-2006 02:08 AM  14 years ago
cowboychris

rrApprentice

Pittsboro, NC, United States

MyPosts All Forum Topic
Sounds to me like you have a servo glitch. One or more of them is probably in a bind at some point in their travel. Check that out and adjust accordingly. Also, the E-flite servos have a tendency to go bad after a hard crash. Check to see that one or more of them isn't humming, or twitching back and forth (with motor spooled up.) I have found servos to be the cause of many evils!
SHARE  PM  EMAIL  Attn:RR  Quote
09-06-2006 07:59 PM  14 years ago
rky5

rrVeteran

Oak Hills california

MyPosts All Forum Topic
I put it in the ground this morning......checked the servos, 2 were almost new actually the other seemed fine.

had it up about 10 mins seem to be ok did several loops on the last one it cut out for a few seconds and I hit the ground. going to need a new frame and blades and landing gear for sure.
I hope after puting it all back to gether I fix the problem, This is starting to bother me!
SHARE  PM  EMAIL  Attn:RR  Quote
WATCH
 1 page 399 views Post Reply
Home✈️Aircraft🚁Helicoptere-BladeOther › Motor cuts out?
Print TOPIC

 1  Topic Subscribe

Thursday, December 3 - 4:04 pm - Copyright © 2000-2020 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online