RunRyder RC
WATCH
 1 page 417 views Post Reply
Home✈️Aircraft🚁HelicopterThunder TigerOther › tt39 plug
09-04-2006 10:09 PM  14 years ago
Topic Vote0Post 1
skyad

rrApprentice

sudbury,on,ca

MyPosts All Forum Topic
tt39 plug
about 3 weeks ago plug fell out while at about 6 feet off ground was able to auto it in no damage (my first auto ever no practice).today as I was doing my sixth backwards flip ,noise pointed str up engine died ( MY FIRST INVERTED AUTO) only damage broke front landing strut and lost a few years off my life.

plugs are in tight, threads not stripped ,why is this happening about 10 gallons on engine ,no problems with first plug 7 gallons (A3)os second same plug ,third tried a enya 3 .Someone at the field suggested locktite???
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
09-05-2006 12:20 AM  14 years ago
Hummingbird3D

rrVeteran

California

MyPosts All Forum Topic
Don't use loctite.

Are you sure you have the copper gasket on? The compression with this copper usually keeps the glow plug on.
Fly It Like You're On The Simulator!
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
09-05-2006 04:43 AM  14 years ago
skyad

rrApprentice

sudbury,on,ca

MyPosts All Forum Topic
copper washer on.
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
09-05-2006 01:50 PM  14 years ago
Rotary R/C

rrApprentice

Sudbury, ON Canada

MyPosts All Forum Topic
You know, I was just thinking: Have you tried going back to the OS plug? I was goin to mention that last night, but it slipped my mind.


Marc
Love my life, love my wife but my heli is my mistress! :D
SHARE  PM  EMAIL  Attn:RR  Quote
WATCH
 1 page 417 views Post Reply
Home✈️Aircraft🚁HelicopterThunder TigerOther › tt39 plug
Print TOPIC

 2  Topic Subscribe

Tuesday, December 1 - 12:02 am - Copyright © 2000-2020 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online