RunRyder RC
WATCH
 1 page 384 views Post Reply
Home✈️Aircraft🚁Helicoptere-BladeOther › first heli and have a ?
07-22-2006 07:52 PM  14 years ago
Topic Vote0Post 1
newguy28

rrNovice

marrero,LA-USA

MyPosts All Forum Topic
first heli and have a ?
I just bought a blade CX and every time I start it back up I have to adjust the trim settings. Is this normal ?
SHARE  PM  EMAIL  Attn:RR  Quote
07-22-2006 08:05 PM  14 years ago
Reb32

rrVeteran

Dunnellon,FL

MyPosts All Forum Topic
Yeah mine is like that also..kinda have to adjust as the battery drains out.. if your fighting with the nose of the Heli turning to the left real bad, do a search on here with "cooling mod on blade cx" and it will show you how to stop it.
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
07-23-2006 12:07 AM  14 years ago
Micro-Maniac

rrElite Veteran

Pasco,Washington Formerly: Captain Chaos

MyPosts All Forum Topic
I have the CP and not the CX but from my use of these and other 4-in-1 controllers I believe that everytime you power up the 4-in-1 it establishes whatever trim you might have as neutral and that your real problem is the proportional gain not dialed in properly making you use tail trim - Therefore if you make a trim adjustment everytime you power up the heli without setting the trim tab back to center each time you will eventually run out of trim intirely.

(it was like this with my old piccolo heli for sure - I haven't even touched the tail trim with my cp)

So instead of using tail trim - Try adjusting the proportional pot on the 4-in-1 and see if that cures it.
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 384 views Post Reply
Home✈️Aircraft🚁Helicoptere-BladeOther › first heli and have a ?
Print TOPIC

 3  Topic Subscribe

Thursday, June 17 - 12:58 am - Copyright © 2000-2021 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online