RunRyder RC
WATCH
 1 page 418 views Post Reply
07-20-2006 12:49 PM  14 years ago
Topic Vote0Post 1
Dr.Phil

rrApprentice

Oslo, Norway

MyPosts All Forum Topic
Revlock problem
Have been using Revlock for quite some time now.
The problem I have is if I for instance give full climbout, and then unloads (0 deg pitch), the hyper seems to loose rpms then pick up the speed again. You can see the smoketrail stop, and then start again.
Other than that it holds the headspeed pretty good. There is no affect ajusting the sensitivity. The Hyper runs smooth without the gov enabled
I tried againg today adjusting the low(idle) and high throttle settings, but still the same problem.
Any tips on what I can check

Its a Raptor 50 with Hyper

Another solution is to use the RevMax I planned to use with my 90.
Can I use the Revlock magnet with RevMax??

Philip
Rave ENV, Stratus BW,Trex700 V-bar,Furion450
www.airheads.no,Team Hobby24
SHARE  PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
07-20-2006 02:36 PM  14 years ago
PaulJC

rrElite Veteran

Hertfordshire UK

MyPosts All Forum Topic
The reason is due to the fact that at 0 deg pitch the hyper will need the throttle virtually closed to maintain the set headspeed and not overspeed, this is completely normal with any gov system and the revmax will perform exactly the same way.Re-entering the atmosphere...
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
07-22-2006 05:23 AM  14 years ago
DMShanks

rrApprentice

Salt Lake City, UT

MyPosts All Forum Topic
Hmm, I have the Revmax and I don't get that "rpm drop" effect. It holds RPM nearly perfectly. Never used the Revmax so can't compare. The Revmax is magic.

Dave
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 418 views Post Reply
Print TOPIC

 2  Topic Subscribe

Thursday, June 17 - 2:26 am - Copyright © 2000-2021 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online