RunRyder RC
WATCH
 1 page 402 views Post Reply
07-18-2006 06:32 AM  14 years ago
Topic Vote0Post 1
djMidnight

rrApprentice

Petaluma, California

MyPosts All Forum Topic
Mystery chirp - help?
I've got a sound coming from my Swift that's like a cross between a loose automotive fan belt and a cricket. I don't appear to have gears rubbing on anything, which is what I first thought.

Does anyone have any other suggestions for what to check? It only seems to happen when I hit my headspeed (about 2000 - 2100) and it makes the tail kick, which suggests either something rubbing, skipping, or resonating, but I can't see anything wrong.

Has anyone ever have trouble with a Neu 1907 / 1.5Y? It's brand new, but since the chirp only seems to happen under load, I thought it might be the rotor slipping on the shaft.

Suggestions welcome,
J
SHARE  PM  EMAIL  HOMEPAGE  Attn:RR  Quote
07-18-2006 07:47 AM  14 years ago
TomC

rrKey Veteran

Gold Coast, Queensland, Australia

MyPosts All Forum Topic
J,

I had a little 'chirp' early on. I removed the main gear and greased up the auto-rotation bearing and the chirp disappeared! You might want to try this before the chirp turns into a loud squeak.

Cheers,

Tom C
Nqx,Mcpx-BL,300x,450x,500x,550x
Ion-x, 10s ,SS
TT X50E 10s, HC3-Sx
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 402 views Post Reply
Print TOPIC

 1  Topic Subscribe

Tuesday, June 22 - 12:39 am - Copyright © 2000-2021 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online