RunRyder RC
 4  Topic Subscribe
WATCH
 2 pages [ <<    <     1     ( 2 )    >    >> ] 924 views POST REPLY
HomeAircraftHelicopterThunder TigerOther › Loosing "grip" when doing engine-demanding manouvers
02-12-2006 02:16 AM  12 years agoPost 21
TAZZY

rrVeteran

Westfield,MA

My Posts: All  Forum  Topic

i love doing repairs and maintenance at the field, that way, you have all the support and diferent ideas from other fliers.
let us know if the one-way was the problem.

GDay

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
02-12-2006 02:17 AM  12 years agoPost 22
TAZZY

rrVeteran

Westfield,MA

My Posts: All  Forum  Topic

20 replies in 1 hour, not bad.

GDay

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
02-12-2006 02:18 AM  12 years agoPost 23
Dr.Phil

rrApprentice

Oslo, Norway

My Posts: All  Forum  Topic

Problem is that I had snow up to my knees while flying today
Not the ideal day for flying if you know what i mean


Philip
Rave ENV, Stratus BW,Trex700 V-bar,Furion450
www.airheads.no,Team Hobby24

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
02-12-2006 02:21 AM  12 years agoPost 24
TAZZY

rrVeteran

Westfield,MA

My Posts: All  Forum  Topic

we haven't had that problem in a few weeks now. this has definetely been a strange winter for us NewEnglanders.
unfortunately they are predicting alot of snow for tomorrow

GDay

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
02-12-2006 02:58 AM  12 years agoPost 25
mystar60

rrVeteran

Clifton, NJ

My Posts: All  Forum  Topic

I would like to hear how you make out with the Revlock turned off. I had used one on my Raptor50 Hyper and the darn head speed went over 2000 upon run up. I am in the process of installing my replacement Revlock but this time I have to configure it with the 14mz radio.
The previous Revlock showed signs of no "soft start" or ramping up the head speed. I was told that I may have had a bad sensor (possible crack on the circuit board).

Kevin

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
02-12-2006 03:07 AM  12 years agoPost 26
Shortman

rrKey Veteran

Portland, Oregon

My Posts: All  Forum  Topic

his caliber would hickup and start running back wards....perfectly.....then would hickup again and go back to normal...I seen this several times just today. If anyone finds the fix for this...please pm rockohaulic.
Lean the low end of the motor, more then likely it is running rich. My Hyper would start and run backwards, but leaned it out 2 clicks on the high end and just a tad on the low end adjustment and it shouldn't happen again.

Team JR
Team ThunderPower RC
Boca Bearings

PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 2 pages [ <<    <     1     ( 2 )    >    >> ] 924 views POST REPLY
HomeAircraftHelicopterThunder TigerOther › Loosing "grip" when doing engine-demanding manouvers
 Print TOPIC  Make Suggestion 

 4  Topic Subscribe

Saturday, June 23 - 5:23 pm - Copyright © 2000-2018 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online