RunRyder RC
 0  Topic Subscribe
WATCH
 1 page 589 views POST REPLY
02-12-2006 12:21 AM  12 years agoPost 1
RadioRob

rrVeteran

Schaumburg Illinois USA

My Posts: All  Forum  Topic

I have a MX-400 that has plenty of head speed but will not go past 2 feet off the ground. I have checked the pitch guage and have a +11 -10 curve but I think its not getting to that point in flight. What could be the problem? I do have an Aluminum Center Hub upgrade, but thats the only new thing I have.

450TH motor
13T pinion
Wood blades
2200mah 3cell


Rob..
TRex-XL
Shogun V1

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
02-12-2006 01:16 AM  12 years agoPost 2
Over Torque

rrNovice

Pocatello, Id.

My Posts: All  Forum  Topic

Check these
Check or replace the auto rotation bearing it may be a bad one or it failed quickly. Try to tighten the set screw on the pinion gear also use blue thread lock on the set screw. When you track the blades make sure that you only adjust the blade that you didn't use the pitch guage on. How heavy is it? My stock MX400 weighs 1.7lbs. I think(which is pretty darn heavy)and it flies great!

PM  EMAIL  GALLERY  Attn:RR  Quote
02-12-2006 01:29 AM  12 years agoPost 3
RadioRob

rrVeteran

Schaumburg Illinois USA

My Posts: All  Forum  Topic

Well its a new heli so I think the auto rotation is OK. I will check the pinion but I can make the blades sing at who knows how fast but with not much lift.

Rob..

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
02-12-2006 01:54 AM  12 years agoPost 4
RC-J

rrNovice

Lexington Ky

My Posts: All  Forum  Topic

Is your pitch servo doing o.k.? It may not be getting to full pitch under load? I had the output shaft of a servo motor spin inside the main gear. When I was on the bench it was fine, under load was another story.

PM  EMAIL  GALLERY  Attn:RR  Quote
02-12-2006 02:34 AM  12 years agoPost 5
RadioRob

rrVeteran

Schaumburg Illinois USA

My Posts: All  Forum  Topic

I think I have found it but wont know for sure until I get it to the dome but what I did was:
1:Max the end point of the pitch to get the most out of it.
2:Move the batt out of the way because I think it was hitting the servo arm.
3:Greased the dampeners and oiled the bushings in the grips.
4:Increased the head speed more than I had.

Seems way better I think the flybar is a 1to1 ratio but I think some slop was making me loose some pitch readings.
Thanks for all your help guys.

Rob..

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
02-12-2006 03:02 AM  12 years agoPost 6
WeatherB

rrVeteran

Toronto - Canada

My Posts: All  Forum  Topic

What headspeed are you running?

Keep in mind that these small 280mm blades require more RPM to produce enough lift.

I run about 2400rpm and can get into a nice hover with about 5 - 6° of pitch.

PM  EMAIL  GALLERY  Attn:RR  Quote
02-12-2006 03:55 AM  12 years agoPost 7
RadioRob

rrVeteran

Schaumburg Illinois USA

My Posts: All  Forum  Topic

I dont have a tach But I bet I had it to slow at first.

Rob..

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
02-12-2006 03:56 AM  12 years agoPost 8
WeatherB

rrVeteran

Toronto - Canada

My Posts: All  Forum  Topic

Most likely... At 2400 it should sound like a bat out of hell (at least indoors).

PM  EMAIL  GALLERY  Attn:RR  Quote
02-12-2006 05:30 AM  12 years agoPost 9
ADRYAN

rrKey Veteran

Stouffville, Ontario, Canada

My Posts: All  Forum  Topic

I'm setting mine at:

Pitch:
Normal = -5, 0, +10
Idle Up = -10, 0, +10
Hold (temp) = -10, 0, +10

Throttle:
Normal = 0, 80, 100
Idle Up = 100, 80, 100
Hold = 0

I'm running:

Feigao Brushless 4462 Kv motor
9 tooth pinion (2 mm. hole for rc cars)
CC25
1320 TP lipo
Futaba GY 190 gyro
HS 55 for tail (waiting on Futaba 3108)
TowerPro 90 (.12 sec on pitch/collective)

So far so good. I'm currently trying to trim collective, tail, revolution mix (rate gyro) and trying to wire the antenna. Some glitching was occuring coz I just ran to the tail fin and back. There were some adjustments apart from the manual in order to get the -+10 pitch.

Try to remember that the peak performance of most motors is at 80%. So on my setup, 80% throttle at 0 degree pitch should put the motor at peak. My CC25 is also set at fixed... works best. I do need 2200 mah tp's... anyway, hope my setup gives you an idea. Good luck.

DYNAX/OS91 : 9303/S649pcm : GY601/9251 : CSMRL10/9253 : 7.4vLipo/Regulator : KO2123s(ai/el/pi)

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
WATCH
 1 page 589 views POST REPLY
 Print TOPIC  Make Suggestion 

 0  Topic Subscribe

Friday, June 22 - 4:29 pm - Copyright © 2000-2018 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online