RunRyder RC
 7  Topic Subscribe
WATCH
 1 page 660 views POST REPLY
HomeAircraftHelicopter
e-
Align
Other › Align 25 amp SC cuts out during flight?
02-10-2006 05:04 AM  12 years agoPost 1
jesse may

rrApprentice

Tempe, AZ

My Posts: All  Forum  Topic

Today was my first flight with my trex fly’s great however ever once in a while the motor cuts out. Kind of like a hiccup. I’m using a TP 2100 with a 430L align motor and there 25 amp SC. I think that it might be that I have my BEC set too high? Any suggestions? I have a CC 25 amp controller that I might swap out. Would this work?

PM  EMAIL  Attn:RR  Quote
02-10-2006 05:30 AM  12 years agoPost 2
jpee67

rrNovice

Nz

My Posts: All  Forum  Topic

Mine did the same,untill it fried itself.
I replaced it with 35amp align and a ferrite ring for noise filtering.
Do a search here about them cutting out there are plenty.

PM  EMAIL  Attn:RR  Quote
02-10-2006 08:45 AM  12 years agoPost 3
Tintin

rrVeteran

Akershus, Norway

My Posts: All  Forum  Topic

I do agree with you finless but I noticed the other day that Align has actually stuffed the 25A in the new X heli together with the 430 so they don't seem to agree with us on that matter...

http://www.align.com.tw/shop/produc...cPath=22_25&;products_id=1147&language=en

“Getting an inch of snow is like winning 10 cents in the lottery.”

PM  EMAIL  Attn:RR  Quote
02-10-2006 09:22 AM  12 years agoPost 4
jpee67

rrNovice

Nz

My Posts: All  Forum  Topic

My kit came with the 430lf and the 25 amp.They might need to rethink their kits.

PM  EMAIL  Attn:RR  Quote
02-10-2006 10:48 AM  12 years agoPost 5
Tintin

rrVeteran

Akershus, Norway

My Posts: All  Forum  Topic

Yup agree to that, I'd never use a 25A with my 430.

“Getting an inch of snow is like winning 10 cents in the lottery.”

PM  EMAIL  Attn:RR  Quote
02-10-2006 02:11 PM  12 years agoPost 6
gkoutsis

rrKey Veteran

Athens Greece

My Posts: All  Forum  Topic

There are different types of 430 motors. One has the same or lower KV than the 420. That could explain why some of you received in a combo with the 25ESC.

George

PM  EMAIL  Attn:RR  Quote
02-10-2006 02:25 PM  12 years agoPost 7
Pistol Pete

rrProfessor

Seffner, FL

My Posts: All  Forum  Topic

this can also be a glitch...related to where electonics are located as well as antenna.

~~Enjoying the hobby one flight at a time~~

PM  EMAIL  HOMEPAGE  Attn:RR  Quote
02-10-2006 02:31 PM  12 years agoPost 8
Edge

rrApprentice

Indianapolis, IN

My Posts: All  Forum  Topic

My experience is that running even the CC35 with the 430L motor puts you on the edge, unless you run a separate BEC. I know there will be differences of opnion on this, but, I think the heat will eventually get you. I toasted a CC35, simply runs too hot powering this motor, 4 servos and gyro! Got a Quark 33 and a Medusa BEC. Everything now cool, even after hard use!

PM  EMAIL  Attn:RR  Quote
02-10-2006 02:38 PM  12 years agoPost 9
Tintin

rrVeteran

Akershus, Norway

My Posts: All  Forum  Topic

The combo ALign has is with the same 3550 kv as the SE.

“Getting an inch of snow is like winning 10 cents in the lottery.”

PM  EMAIL  Attn:RR  Quote
02-10-2006 02:45 PM  12 years agoPost 10
gpison

rrNovice

Boca Raton, Fl

My Posts: All  Forum  Topic

My Trex has been flow 4 times so far. Just minor stuff around the yard. Last night was the 5th flight and I was getting a hiccup in the motor as well. I have the 420 with the 25 amp esc. Before the battery pack was done the speed control fried itself. It almost melted through the frame of the Heli.

I am going to go pick up a Quark today I guess.

PM  EMAIL  Attn:RR  Quote
02-11-2006 05:50 AM  12 years agoPost 11
Anderman

rrNovice

Thornton, CO

My Posts: All  Forum  Topic

I have the same problem with the hicup. Same 25 esc and the 420lf motor. Does anyone have the fix? Is there an align technical support that we can get in touch with?

PM  EMAIL  Attn:RR  Quote
02-11-2006 09:47 AM  12 years agoPost 12
Rob_T

rrElite Veteran

..

My Posts: All  Forum  Topic

I had the same issues with a 420LF and both the Align 35A and CC35. (The Align was much worse, but the CC still did it). The problem went away when I switched from a regular PPM receiver to a Spektrum 2.4GHz system. I need to get a few more hours on the Spektrum to be sure, but it does seem to have fixed it...

PM  EMAIL  Attn:RR  Quote
02-11-2006 07:56 PM  12 years agoPost 13
Anderman

rrNovice

Thornton, CO

My Posts: All  Forum  Topic

I have read some of the other threads on this and it seems like the only things that have fixed the problems is using a different motor and different ESC. Has any one had any luck using the toroid fix or the fix that finless suggests?

PM  EMAIL  Attn:RR  Quote
02-11-2006 09:31 PM  12 years agoPost 14
Garber16

rrNovice

My Posts: All  Forum  Topic

I had the same problem - switched to PCM, worked fine, no cut-outs. Didn't get three flights on it, though, because my T/R blade pulled right out (make sure you are using the newer steel version).

PM  EMAIL  Attn:RR  Quote
02-11-2006 09:57 PM  12 years agoPost 15
StuUK

rrNovice

UK

My Posts: All  Forum  Topic

I had exactly the same issue with a new 3550kv 430L and the align 35amp esc. Looked at everything on the heli that might be causing glitcing etc but still got at least one or two momentary motor cuts every flight. Eventually i had my supplier replace the esc with the same type and the problem went away. Also the new esc is giving me 20% longer flights

PM  EMAIL  Attn:RR  Quote
02-12-2006 03:42 AM  12 years agoPost 16
Anderman

rrNovice

Thornton, CO

My Posts: All  Forum  Topic

This is just a thought but does the glitch come from something outside the receiver? Or is it that reciver module creating the glitch? Has anyone tried wrapping the ESC with tin foil to isolate it from rf noise? Just a thought.

PM  EMAIL  Attn:RR  Quote
02-13-2006 02:44 AM  12 years agoPost 17
Anderman

rrNovice

Thornton, CO

My Posts: All  Forum  Topic

Does anyone put a ground wire from there boom to the battery negative? I tried this and I also braided the ESC to motor wires. I have just used a whole battery without a glitch. I will try and go through another couple of batteries tommorrow but it seems so far that this has possible fixed my problem?

PM  EMAIL  Attn:RR  Quote
WATCH
 1 page 660 views POST REPLY
HomeAircraftHelicopter
e-
Align
Other › Align 25 amp SC cuts out during flight?
 Print TOPIC  Make Suggestion 

 7  Topic Subscribe

Sunday, June 17 - 11:17 pm - Copyright © 2000-2018 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online