RunRyder RC
 1  Topic Subscribe
WATCH
 1 page 603 views POST REPLY
HomeAircraftHelicopter
e-
Elec-Helicopters New or Limited Activity
Ark › MX-400 elevator/pitch coupling
02-09-2006 09:52 PM  12 years agoPost 1
Tioli

rrVeteran

Kona, Hawaii

My Posts: All  Forum  Topic

I have an MX-400 Pro with S-75 servos all around. Mechanical mixing. Using a JR 6102. Everything wiggles the right way.

As I bring up the the collective the swash plate tilts significantly forward. The elevator servo is not moving in any way. The elevator arms seem to be dragging at the rear of the swashplate, but I can't find any ACTUAL binding. I can finesse it so that around hover the swash is level, but any less collective causes the swash to pitch forward.

What am I doing wrong? Do I just need to upgrade to CCPM?

d

PM  EMAIL  GALLERY  Attn:RR  Quote
02-09-2006 10:06 PM  12 years agoPost 2
Cromer

rrApprentice

Germantown, NY

My Posts: All  Forum  Topic

I can't speak for the mechanical setup of the MX400 as far as flying goes because I went right to the CPPM upgrade before I even flew it. I had a couple of different reasons. First there is a lot more room up front with the collective tray out of the way. I also had trouble with the one collective bellcrank rubbing on the elevator linkage and the dreaded elevator arm slop issue. I got the regular metal frame upgrade and not the carbon fiber one mostly because I am still very capable of putting the thing in and didn't want to waste the money. You get the metal swash in the kit and you get rid of the z bends and get ball links on all the linkages also. When done you have a direct link from the servos to the swash which I think is a much better way to go. I am very happy with the decision. That being said I have seen posts from folks that are more than happy with the stock setup so I guess it is up to the individual to sift through all the info and come to their own conclusion.

Phil

PM  EMAIL  GALLERY  Attn:RR  Quote
02-10-2006 05:34 AM  12 years agoPost 3
BikeNBoatN

rrVeteran

Santa Ana, CA USA

My Posts: All  Forum  Topic

Make sure the anti-rotation pin is not dragging in the anti-rotation slot. That's a known problem. I had to file the inside edges of the slot (widen the slot) on my MX to avoid a problem similar to what you're having.

Brent.

PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 603 views POST REPLY
HomeAircraftHelicopter
e-
Elec-Helicopters New or Limited Activity
Ark › MX-400 elevator/pitch coupling
 Print TOPIC  Make Suggestion 

 1  Topic Subscribe

Monday, June 25 - 3:35 am - Copyright © 2000-2018 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online