RunRyder RC
 3  Topic Subscribe
WATCH
 1 page 507 views POST REPLY
02-08-2006 03:13 AM  12 years agoPost 1
kobe larry

rrApprentice

Kobe Japan,Thailand,Vanco uver Can.

My Posts: All  Forum  Topic

My 4000 pack is dead when I took it out of the heli it said 7.9 when I checked it. It sat on my table for two weeks pluged in to the regulator,I was going to put it in another Heli when I checked it again it will not show any thing.I am not sure if I sould try to charge it

PM  EMAIL  Attn:RR  Quote
02-08-2006 03:19 AM  12 years agoPost 2
rickc

rrElite Veteran

Creve Coeur IL. (Peoria Area)

My Posts: All  Forum  Topic

You killed it, I really don't think you should try to charge it and really don't think it would take a charge any way. Write that off to leaving in plugged into a regulator drawing on it for two weeks. I'm sure it's a mistake you will not make again.

Rick

PM  EMAIL  HOMEPAGE  Attn:RR  Quote
02-08-2006 05:03 AM  12 years agoPost 3
kobe larry

rrApprentice

Kobe Japan,Thailand,Vanco uver Can.

My Posts: All  Forum  Topic

I understand that it is dead. I do not understand why.If I leave it in my heli it is pluged in to the regulator and not on,and it can sit for weeks with out loseing any power. Why then did it die?

PM  EMAIL  Attn:RR  Quote
02-08-2006 05:09 AM  12 years agoPost 4
RobRoy

rrKey Veteran

Huntsville, Alabama

My Posts: All  Forum  Topic

Was it a switched regulator? if not, and you plug it into the regulator it will slowly drain the battery. You will not be able to charge it with the duralite charger if it is completely dead, you will need to give it a little juice with some other charger first, then you will still only have a small chance that the battery is still good. Trust me, I know this.

Ignorance is curable, stupidity is for life.

PM  EMAIL  Attn:RR  Quote
02-08-2006 05:20 AM  12 years agoPost 5
Bobby Watts

rrVeteran

Orlando, FL

My Posts: All  Forum  Topic

Try to charge it up. What voltage does it read with no load.... with 1 amp load???

www.bobbywatts.com

PM  EMAIL  HOMEPAGE  Attn:RR  Quote
02-08-2006 05:28 AM  12 years agoPost 6
kobe larry

rrApprentice

Kobe Japan,Thailand,Vanco uver Can.

My Posts: All  Forum  Topic

it does not read any thing.

PM  EMAIL  Attn:RR  Quote
02-08-2006 05:29 AM  12 years agoPost 7
RobRoy

rrKey Veteran

Huntsville, Alabama

My Posts: All  Forum  Topic

yep...completly dead...that's why the duralite charger won't work....is needs to sense some voltage. I've been through this....my pack was fried after all said and done.

Ignorance is curable, stupidity is for life.

PM  EMAIL  Attn:RR  Quote
02-08-2006 05:55 AM  12 years agoPost 8
kobe larry

rrApprentice

Kobe Japan,Thailand,Vanco uver Can.

My Posts: All  Forum  Topic

I put it on the tritron and it reads 5.80 but under load it drops off fast. the triton keeps saying votage input era I only have a triton charger here in tailand the power is not the same as canada so I brught the triton to charge with charging at 1 or .5 it does the same.

PM  EMAIL  Attn:RR  Quote
02-08-2006 11:52 AM  12 years agoPost 9
Bobby Watts

rrVeteran

Orlando, FL

My Posts: All  Forum  Topic

I think it's time for a new pack...

www.bobbywatts.com

PM  EMAIL  HOMEPAGE  Attn:RR  Quote
WATCH
 1 page 507 views POST REPLY
 Print TOPIC  Make Suggestion 

 3  Topic Subscribe

Monday, June 18 - 2:09 pm - Copyright © 2000-2018 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online