RunRyder RC
 2  Topic Subscribe
WATCH
 1 page 555 views POST REPLY
HomeAircraftHelicopter
e-
Blade
Other › Blade CP on 3-cell lipo
02-07-2006 12:13 PM  12 years agoPost 1
jjp735i

rrApprentice

Pittsburgh, PA

My Posts: All  Forum  Topic

Why does my motor overheat if I use this combo. 1300-3 cell lipo, 9t motor, sym. blades. I get about 3 minutes flight time and it dies. If I use the flat bottoms with 8t motor same battery. I can fly for 15 minutes and motor doesn't even get hot. Sym. blades are new and in perfect shape. I can also fly the flats with the 9t and get 15 or more minutes of flight time.

Thanks, jjp

PM  EMAIL  Attn:RR  Quote
02-07-2006 12:47 PM  12 years agoPost 2
Motions

rrVeteran

Tallahassee, FL

My Posts: All  Forum  Topic

I can only think your motor is going bad. With a 9T and 3-cell you shouldn't be getting hot. You may want to try the 8T with the sym blades and see hoe that works. You will loose a little headspeed but should gain flight time and run cooler.

PM  EMAIL  HOMEPAGE  Attn:RR  Quote
02-08-2006 12:37 AM  12 years agoPost 3
Gary Hoorn

rrKey Veteran

Annapolis Maryland USA

My Posts: All  Forum  Topic

Sounds like time for a replacement 9 tooth motor. I had the same symptoms. The motor goes bad and just stops, usually followed by a "whump" that requires some new parts!
Gary

PM  EMAIL  Attn:RR  Quote
WATCH
 1 page 555 views POST REPLY
HomeAircraftHelicopter
e-
Blade
Other › Blade CP on 3-cell lipo
 Print TOPIC  Make Suggestion 

 2  Topic Subscribe

Monday, June 18 - 4:51 am - Copyright © 2000-2018 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online