RunRyder RC
WATCH
 1 page 548 views POST REPLY
01-14-2006 12:59 AM  13 years ago
Topic Vote0Post 1
wags

rrNovice

Waterloo, IL USA

MyPosts All Forum Topic
Duralite 3 + 1 charger
I just purchased the duralite setup w/the 3+1 charger. If I plug my receiver pack into plug 1, LED lights up. Plug into port 2, LED lights up. Plug into port 3, no LED. I tried the same with my glow driver/load tester. Bad LED, or no power output?
I know, I will call duralite, however it is Fri night and it will drive me nuts all weekend.
Thanks,
Steve
SHARE  PM  EMAIL  Attn:RR  Quote
01-14-2006 01:17 AM  13 years ago
RayJayJohnsonJr

rrKey Veteran

Midwest

MyPosts All Forum Topic
Drop them an e-mail anyway. You may just get a reply yet tonight.

-Mark
There, their and they're. It's really that simple.
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
01-14-2006 01:59 AM  13 years ago
wags

rrNovice

Waterloo, IL USA

MyPosts All Forum Topic
Thanks, however when I clicked on the contact link, it went to outlook. I don't have outlook, wouldn't go through. Tried to e-mail through my normal server, and came back undeliverable.
SHARE  PM  EMAIL  Attn:RR  Quote
01-14-2006 04:53 AM  13 years ago
montarok

rrKey Veteran

Brooklyn, NY

MyPosts All Forum Topic
Funny, I'm having some problems with the same type of chager. When I had only 1 pack, it was all good, but when I bought 2 more packs I noticed the problem. When I plug all 3, 2 will charge normally, but the third LED never goes off and the pack is never fully charged.
SHARE  PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
01-14-2006 07:27 PM  13 years ago
wags

rrNovice

Waterloo, IL USA

MyPosts All Forum Topic
Have you contacted duralite? I will have to wait until Monday, I guess.
SHARE  PM  EMAIL  Attn:RR  Quote
01-14-2006 08:26 PM  13 years ago
Flyinrazrback

rrVeteran

Fort Smith, AR

MyPosts All Forum Topic
I dont think duralite checks emails, ever, never got one from them. It sounds like a bad port in the charger. I went through 4 new chargers from them before I got one that all the ports worked, so call them and they will send you a new one. I think they had a bad run of chargers, and you may have got one of those.
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
01-16-2006 11:39 AM  13 years ago
gt900uk

rrKey Veteran

Scotland

MyPosts All Forum Topic
I do had problems with 2 chargers from them doing the same thing. Also when some of the LED's had gone off if you touched the charger they would come back on again very strange.This Heli Will Self Destruct In Five Seconds!!
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
01-16-2006 12:19 PM  13 years ago
RayJayJohnsonJr

rrKey Veteran

Midwest

MyPosts All Forum Topic
I received 2 4000mah packs from Duralite a couple of months ago. 1 flat and one square. One of them, don't recall which one, had the same problem. Light on charger would not go off. I have a 4 port Duralite charger and it exhibited this problem regardless of which port is was plugged in to. I called them and the sent me a new one and wanted the 'bad' one back. The pack that they sent as a replacement works just fine. Something to do with the 'charge safe' circuitry in the pack?

-Mark

.
There, their and they're. It's really that simple.
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
01-17-2006 12:11 AM  13 years ago
wags

rrNovice

Waterloo, IL USA

MyPosts All Forum Topic
I called Duralite today, spoke with Mark. He said a new charger would ship to me immediately. He will also send return information for the other charger. For anyone that complains about duralite prices....customer service is worth every penny!
SHARE  PM  EMAIL  Attn:RR  Quote
WATCH
 1 page 548 views POST REPLY
 Print TOPIC  Make Suggestion 

 1  Topic Subscribe

Monday, September 16 - 7:08 am - Copyright © 2000-2019 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online