RunRyder RC
WATCH
 1 page 649 views POST REPLY
01-13-2006 09:45 PM  13 years ago
Topic Vote0Post 1
crashu2

rrNovice

IRELAND

MyPosts All Forum Topic
stratus build question
I am currently building a stratus,left frame is complete and have started the right one,when i go to mount the elevator bellcrank into the left frame the canopy mount is already in it as per photo and instructions,on the photos for the right frame the mount is way below the instructed place on the left,as well as this i am mounting a fury canopy and not the stratus one ,i guess what iam asking is exactly where does the canopy mount on a stratus go if you want to use a fury canopy??????sorry if this is confusing
SHARE  PM  EMAIL  Attn:RR  Quote
01-13-2006 11:08 PM  13 years ago
Coloradoheli3d

rrApprentice

Colorado USA

MyPosts All Forum Topic
If you rmounting a Fury canopy the mounts go into the tail boom bolts one hig and one low. If you look at page 52 you'll see that the axil for the ele bellcrank gose in the lower front hole and the post for the servo support gose in the top rear hole, there are three holes there. Sounds like you have it in the wrong hole.
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
01-13-2006 11:36 PM  13 years ago
crashu2

rrNovice

IRELAND

MyPosts All Forum Topic
thanks for the reply,but if the bell crank goes in the top hole it means that the servo support is lower than the support at the back,have you any pics that i could see please
SHARE  PM  EMAIL  Attn:RR  Quote
01-16-2006 04:11 PM  13 years ago
Coloradoheli3d

rrApprentice

Colorado USA

MyPosts All Forum Topic
Go to MA's website and you can download the inscructions and look on page 52 that should fix you all up.
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 649 views POST REPLY
 Print TOPIC  Make Suggestion 

 1  Topic Subscribe

Monday, September 16 - 11:44 pm - Copyright © 2000-2019 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online